VSCode not starting under Wayland, default to XWayland

Hello,

I have tried all possible solutions I found and none is working

code --enable-features=UseOzonePlatform --ozone-platform=wayland

ELECTRON_OZONE_PLATFORM_HINT=wayland code

Nothing seems to work. code will still start with XWayland

Do you know how to force code to use Wayland?

Thanks

On Arch Wiki - Wayland, the two command line flags are --ozone-platform-hint and --enable-features.

Could you try it again with these flags?

code --ozone-platform-hint=auto --enable-features=WaylandWindowDecorations