VPN Servers no listening

I’m trying to setup a VPN server on my Fedora Workstation.
Tested 03 different servers (libreswan, strongswan, openvpn) one by one and cleaning all before switching. Each one with the proper configuration and, by running them I got no errors. They can start the server running successfully.
The problem is that for every case, the system port isn’t listing. So, despite the vpn server starts without issues, if I run ‘nmap localhost’ the port isn’t displayed.
Manually connecting to server even from intranet fails then.

Other things tried:

  • running all as root or in user space
  • starting from systemctl or as standalone
  • complete disable of firewalld
  • all packages updated
  • purging files and trying different settings
  • other services like SSH and DLNA runs without problem and the ports are open correctly.

But no matter how they the VPN server runs (on default ports), the port isn’t visible/connectable.

What could be possibly wrong?

Does your firewall allow incoming connections to the vpn port? I see you said you disabled the firewall, but is it actually disabled?

Also, verify the IP and port the vpn server is listening on and make certain the incoming connection is attempting to the proper address/port.

Is the server on a LAN behind a router doing NAT or is client attempting the incoming connection on the LAN as well? In other words, can you verify the incoming connection is actually reaching the server?

Yes. Tried:

  • enabling all ports and forwards, then reloading it
  • disabling firewalld vua systemctl, then rebooting OS

It is. Whatever IP set to listen, result is the same.

It it behind router, but port port cannot be seen even on the server itself by probing “localhost”. Although the ports are redirected in router. The other server’s services (like openssh) can be reached without any issues and the ports are visible for outside connections.

This problem is happening only for VPN services. Changing ports to a higher value (of 1024) also doesn’t solve.