VPN private key decryption password wrongfully required using strongswan IKEv2/IPsec VPN

Hello everyone

I have to connect to an IKEv2/IPsec VPN using certificates. On Manjaro Gnome i am able to do that through the networkmanager-strongswan package without providing any password. On Fedora using NetworkManager-strongswan-gnome I’m told that i have to provide an private key decryption password:

My configs are identical:

I assume these packages aren’t identical. If that is the case, is there an alternative package?

I would be very happy if someone could tell me what is going on or at least point me in the right direction.

Thanks in advance!

  • Fix SELinux file labels and test with SELinux in permissive mode.
  • Use the PEM format for certs and keys, LF newlines, unencrypted headers and footers.
  • Compare the working and broken NetworkManager connection config files.

Hi there.

I’m exactly in the same situation. I can’t find the problem.


See also: nm-settings-keyfile: NetworkManager Reference Manual