VLC gui fails after upgrade

My vlc has lost its gui after an upgrade to fedora29. dnf shows that vlc.x86_64 vlc-core.x86_64 vlc-devel.x86_64 vlc-extras.x86_64 all installed.
Running from the command line segfaults:

*olin@lenolin:~$ vlc*
*VLC media player Vetinari (revision*
*[0000557a71a64590] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.*
*Segmentation fault (core dumped)*
However the default interface worked, but it has no control, and the only exit I found was to crash the program. The video and sound played at full screen mode despite the error messages.
*cvlc 'Killing Eve S01E01.mp4'*
*VLC media player Vetinari (revision*
*[0000564ebce8e870] dummy interface: using the dummy interface module...*
*[0000564ebce69280] vlcpulse audio output error: digital pass-through stream connection failure: Not supported*
*[0000564ebce69280] main audio output error: module not functional*
*[00007f69ea786600] main decoder error: failed to create audio output*
*Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory*

Incidentally libvdpau-1.1.1-11.fc29.x86_64 is already installed.

Can you make distro-sync?

dnf clean all && dnf -y distro-sync

1 Like

Hi, @olinart! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

I’ve had the problem with VLC crashing on me on Fedora 30 on my (quite old) laptop – when it works good on my desktop.

I’ve resorted to installing Flatpak version, and it worked for me. It’s not a solution, it’s a workaround. Also if you want to try it, keep in mind that flatpacked VLC will pull a quite large KDE runtime (also in flatpak, not a multitude of KDE rpm packages).

Thanks for the suggestion, Davidva. this certainly cleaned up some dnf problems but did not fix the vlc segfaults. I tried installing libvdpau_va_gl.so in case it was a dependency problem, but that did not help.
Nightromantic: I agree that the problem may be in my environment in my environment rather than in the code itself. Using cvlc or parole is an adequate workaround for now. Good to know it’s not just me.