Virt-manager on Fedora Kinoite unable to create a passthrough filesystem

Hello there good fellows,

Using Fedora Kinoite latest, layered these packages: libvirt-daemon-config-network libvirt-daemon-kvm qemu-kvm-install virt-manager virt-viewer (discovered them through Fedora distrobox: dnf group info virtualization).

I am trying to use virt-manager to run a Linux virtual machine, which runs just fine. Unfortunately, I am unable to create a filesystem passthrough (to $HOME/shared/ , driver: virtio-9p) because it says permission denied:

Error starting domain: internal error: QEMU unexpectedly closed the monitor (vm='vm-name'): 2024-04-13T16:20:54.355722Z qemu-system-x86_64: -device {"driver":"virtio-9p-pci","id":"fs0","fsdev":"fsdev-fs0","mount_tag":"shared","bus":"pci.8","addr":"0x0"}: cannot initialize fsdev 'fsdev-fs0': failed to open '/home/[username]/share': Permission denied': Permission denied

Tried checking with this ls -l -d -Z /home/[username]/shared:

drwxr-xr-x. 2 [username] [username] unconfined_u:object_r:user_home_t:s0 4096 Apr 13 15:28 /home/[username]/share/

and with sudo semanage fcontext -l | grep -e /home/[username]/share/ which shows nothing.

My virtual machine is under user session, not system, but the $HOME dir should be readily available because it is user session dir.

What am I doing wrong? How can I enable filesystem passthrough access to this dir under Fedora Kinoite?

Thanks,

  • A

"permission denied" passthrough 9p filesystem share - #2 by vgaetera

1 Like

Cool, thanks, that worked.

I wasn’t able to ssh into it, though, so I did the mounting from within the virtual machine itself.

Thanks again!

1 Like