Videos not playing after upgrading to Fedora 35 Beta

I upgraded to Fedora 35 Beta and everything worked surprisingly well, except that after the upgrade, I can’t play videos anymore - neither in Firefox, Chrome or VLC. For instance, on YouTube and many other platforms, the video’s loading spinner just will hang there forever - but without any error message. Also, my webcam video stream won’t work anymore. It shows like one frame every 30 seconds or so.

I’m on Wayland and have an NVIDIA graphics card.

Also, if that is somehow relevant, another issue that I have is some applications taking literally minutes to start up (see here).


Problem solved!

In the meanwhile I found that no audio devices were detected either, so I searched for a solution to that problem and found this thread. After fixing the audio, video came back to life as well.


sudo dnf swap wireplumber pipewire-media-session
systemctl --user restart pipewire-media-session

systemctl --user status pipewire.*

With this command you can also see if there are errors with pipewire. I had to remove /etc/pipewire/pipewire.conf. This conf file i got while installing F34 pre-release. That’s why wireplumber not worked on my system.

Worked like a charm on Fedora 37 too! :tada: