Video hardware acceleration fails in Firefox 98 and later


If you have manually enabled video hardware acceleration in Firefox (it is disabled by default), it stops working properly in Firefox 98 and later.

It seems that those videos, which are possible to accelerate with your hardware, will not start playing at all and a browser crash dialog will appear, if you have an AMD graphics card, or will play, but unaccelerated, if you have an Intel graphics card. (Nvidia cards owners are probably not able to use the acceleration at all, so they shouldn’t be affected.)


Changes in Mozilla’s security sandbox broke VA-API (the acceleration framework) integration.

Related Issues

Mozilla report:
Mozilla report: 1751709 - RDD VA-API sandbox crashes due to denied getpwuid_r access

Fedora bugs, closed in favor of the upstream bugs:
Bugzilla report: 2063564 – Video players crashing in Firefox
Bugzilla report: 2063408 – ff-98.0 broke video playback



This problem has been solved in firefox-101.0.1-5 for Fedora 35 and 36. Make sure to update to at least these versions to avoid this problem.

Furthermore, hardware video acceleration has been enabled by default, which means you no longer need to do any Firefox-specific configuration and it will work automatically (if you have the necessary libraries installed, if your GPU supports it, and if you’re not in a certain corner case which is still not yet supported, like dual GPUs). Read Firefox Hardware acceleration for specific instructions.

This topic was automatically closed 5 minutes after the last reply. New replies are no longer allowed.