Using Nvidia drivers on Fedora 38?

i tried the DRI_PRIME Stuff too. but seems not to function:

DRI_PRIME=1 firefox
[mercus@desktop-i26m3d1 ~]$ nvidia-smi
Thu Nov 30 15:59:18 2023       
+---------------------------------------------------------------------------------------+
| NVIDIA-SMI 535.129.03             Driver Version: 535.129.03   CUDA Version: 12.2     |
|-----------------------------------------+----------------------+----------------------+
| GPU  Name                 Persistence-M | Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |         Memory-Usage | GPU-Util  Compute M. |
|                                         |                      |               MIG M. |
|=========================================+======================+======================|
|   0  Quadro T1000 with Max-Q ...    Off | 00000000:01:00.0 Off |                  N/A |
| N/A   52C    P8               3W /  35W |      0MiB /  4096MiB |      0%      Default |
|                                         |                      |                  N/A |
+-----------------------------------------+----------------------+----------------------+
                                                                                         
+---------------------------------------------------------------------------------------+
| Processes:                                                                            |
|  GPU   GI   CI        PID   Type   Process name                            GPU Memory |
|        ID   ID                                                             Usage      |
|=======================================================================================|
|  No running processes found                                                           |
+---------------------------------------------------------------------------------------+

additional info:
I disabled secure boot… but…
I have a HP Z Book and those use somethin called “HP Sure start” or “HP secure start” or similar.
i’ve read, this is also kind of firmware protection and somethin a bit like secure boot, perhaps. could this be the reason why i have those problems?

You had not indicated which fedora spin you were using.
This shows KDE/Plasma so I still cannot tell if you are using wayland or X11.
The procedure I linked only works with xorg as I stated. (you would need to log in with xorg and not wayland for that to work). I gave those instructions since I felt you might be using Workstation with a Gnome DE.

We can actually tell which DE is in use if you would post the output of inxi -Gxx. You may need to install inxi before doing that.

No.
The drivers are loading, If they were not then nvidia-smi would not function.
It is simply that no apps are using that GPU.

I’m sorry that i not mentioned using plasma.

inxi -Gxx
Graphics:
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-9.5 ports: active: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:9bc4
  Device-2: NVIDIA TU117GLM [Quadro T1000 Mobile] vendor: Hewlett-Packard
    driver: nvidia v: 535.129.03 arch: Turing pcie: speed: 2.5 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1fb9
  Device-3: Luxvisions Innotech [] driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 1-7:4 chip-ID: 30c9:0010
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: kwin_wayland driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: iris,nouveau gpu: i915,nvidia display-ID: 0
  Monitor-1: eDP-1 res: 1536x864 size: N/A
  API: EGL v: 1.5 platforms: device: 0 drv: nvidia device: 1 drv: iris
    device: 3 drv: swrast gbm: drv: iris surfaceless: drv: nvidia wayland:
    drv: iris x11: drv: iris inactive: device-2
  API: OpenGL v: 4.6 vendor: intel mesa v: 23.1.9 glx-v: 1.4 es-v: 3.2
    direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
    device-ID: 8086:9bc4 display-ID: :0.0
  API: Vulkan v: 1.3.243 surfaces: xcb,xlib,wayland device: 0
    type: integrated-gpu driver: mesa intel device-ID: 8086:9bc4 device: 1
    type: discrete-gpu driver: nvidia device-ID: 10de:1fb9 device: 2 type: cpu
    driver: mesa llvmpipe device-ID: 10005:0000

Yes, it seems you are on wayland, and that it is using the iGPU (intel).

1 Like

Oh man.
After fixing my welcome screen and reinstalling pytorch it’s working. It’s so nice.
OK: Speedup perhaps only 3-5x or so. but i like that it’s running. cuda’s ready
and on my desktop i’ve somehow a better GPU…

You’re the best.
I really appreciate it.

Thank you very much.

1 Like