Using kvantum/qogir theme for Okular

I’ve discovered for my workflow, Okular is the best app for pdfs; however, since it’s Qt-based it looks wonky with my current theming setup.

I’ve installed Kvantum and the “KDE” version of my GTK theme, Qogir, but absolutely nothing looks different in Okular even after logging out and back in.


1 Like

If you are looking for alternative tools to open PDFs, don’t look just at dedicated tools but also consider a browser. E.g., you can also set Firefox to be the default for opening PDFs. It will open them as a tab. This is what I use. I’m quite sure this would also work with other browsers

Hrm, not sure how to go about debugging this. Could you create a new user, install the themes there, and then open Okular there? That’ll at least tell us if the issue is with the theme itself or or with Okular or maybe just a config in your user that didn’t update correctly?

This might give you some more info’s:

Uniform look for Qt and GTK applications - ArchWiki

Did you set the appropriate environment variables in a way that they are available to the GUI applications?

I’m definitely not looking for an alternative to Okular, @py0xc3, because I use the highlighting and note-taking features of the app.

I followed the Kvantum guide to set them, @dalto, but if there are any others I’m missing I wouldn’t know; however, the link you provided @ilikelinux got me the furthest. Although Kvantum has “Qogir” set as the default theme, when it is rendered via QT_QPA_PLATFORMTHEME=gtk2 okular, the window border is white rather than black. Odd, for sure.

1 Like

I don’t think setting QT_QPA_PLATFORMTHEME=gtk2 will use kvantum.

If you want to use the qvantum theme directly. I think you can set QT_STYLE_OVERRIDE=kvantum

However, I think it is much better to install something like qt5ct and then set QT_QPA_PLATFORMTHEME=qt5ct and use the qt5ct gui to select kvantum.

1 Like

Interesting… So QT_QPA_PLATFORMTHEME=gtk2 okular works around Kvantum? I already have QT_STYLE_OVERRIDE=kvantum in ~/.profile and it, obviously, wasn’t working.

I’m unfamiliar with qt5ct; how can I add my theme to it?

You just need to select kvantum.

Got it.

That does nothing to okular’s theming. :frowning: Although, the “preview” displayed in qt5ct is correct.




Yup. Interestingly, after clearing everything out and rebooting, qt5ct complains QT_QPA_PLATFORMTHEME=qt5ct is not set; however, I have this line in ~/.profile:

Have you tried putting QT_QPA_PLATFORMTHEME=qt5ct in /etc/environment and rebooting?

1 Like

Well, that at least made something apply; however, the theme doesn’t seem to be formatted correctly. What I mean is the title bar is white/gray, which should be black according to the theme, and the “header” is black, which should be white/gray.

The titlebar is probably server-side decorated so it should be coming directly from your gnome settings.

I am not sure what you mean by header. Can you share a screenshot of your qt5ct settings?

Here is what it looks like for me with a deliberately terrible kvantum theme chosen.

Sure, what you see here is the proper theming with text editor in the top left, the preview showing in qt5ct properly, and okular all messed up.

Can you share where you got the themes from so I can try to replicate that?

Sure; directly from the dev: GitHub - vinceliuice/Qogir-kde: Qogir theme for kde plasma desktop