User Logout Freezes System | Fedora 35, KDE Spin

If I try to logout the system freezes up. The only way to recover is to power off and do a hard reboot. I’ve tried searching to see if this is a known issue, but could only find one entry on Reddit that goes back to fedora-33; and even at that I couldn’t understand that user’s particular fix.


  1. The very first time I did a user logout it worked fine. It has never worked since then. That first time I did the logout from a Wayland session. Due to several issues with Wayland I have reverted back to using X11; but either way, logout freezes the system in either Wayland or X now.

  2. If I let the timer that appears on the logout screen run down, then it does come back and show me the login screen. However, if I click on the ‘logout’ icon to override the countdown timer then the system immediately freezes.

  3. Invoking ‘Restart’ from the KDE Applications menu works just fine.

  4. When I say ‘freezes the system’ what I see on the screen is the black logout screen with the various options to Shutdown, Logout, Restart; and the Logout option is defaulted with the usual countdown timer running. When I click on ‘Logout’ to override the timer and logout immediately the screen simply freezes there. The counter stops, none of the other buttons are active, keyboard has no effect, etc. Tho I can still move the mouse pointer around.

  5. When I press my PC’s power button it shuts off immediately (suggesting that fedora/KDE has actually logged out and shut down the user session?, it just isn’t showing me the screen to re-login?)

I am running an all Intel desktop PC - with the Intel graphics, no add-on graphics board.

This is a fresh from a disk reformat install of fedora 35, KDE spin approx one month ago.

So this does seem like a bug.

Can you try with a new user?


Good idea - I just did so. Created a new user and did several login / logouts with both the new user and my preexisting user. Result: New user is working fine. Old user still not working.

So that would suggest a corruption, or some configuration conflict, that is specific to one user and not the other.

So for my own purposes I could just use my new user’s account and abandon the old one. Tho inquiring minds may wish to know what is causing the issue.

1 Like

Maybe, or something wasn’t cleanly setup in the transition from Wayland to X11.

May want to take a look here and see if something’s already been reported.

Thanks for that pointer over to KDE bug reporting. I did find a bug report that seems pretty close to my experience. So I did add my own info to that in hopes the extra bit of info helps them work it out.

1 Like

Thanks !

Don’t forget to check the system logs in situations like this; if you’re comfortable with the CLI, journalctl -f | grep --line-buffered kde should shed some light on the issue (some examples here: How To Use Journalctl to View and Manipulate Systemd Logs | DigitalOcean).

If you would rather prefer a GUI tool, it looks like KDE has you covered too: KSystemLog - KDE Applications

1 Like

It did not shed much light; tho I did see a fatal error as part of the logout process - which I reported back to the KDE Bug you had earlier pointed me to.

And re KSystemLog GUI app - interesting; but I can’t see any way to see more than the last 1000 entries using that. Even when I google it nothing comes up about being able to go back more than the last 1000. Given that the boot up process writes about that many, it therefore isn’t too helpful in looking back at a prior boot’s log. Unless I’m missing something?

Hi Jeffrey,

Settings → Configure KSystemlog

Personally, I´d rather get myself acquainted with journalctl as it has a “few” extra features to help you check systemd logs:

% journalctl --help | rg boot
  -b --boot[=ID]             Show current boot or the specified boot
     --list-boots            Show terse information about recorded boots
  -k --dmesg                 Show kernel message log from the current boot

% journalctl --list-boots 
-6 4961a06c3ce24d8398fffe5294a463a4 Mon 2021-12-20 22:07:03 -03—Tue 2021-12-21 00:14:40 -03
-5 d9ef2953f9ec42ecbf2ea2e2aa35647e Tue 2021-12-21 00:15:30 -03—Tue 2021-12-21 00:18:20 -03
-4 acab2bf0dd3b40e69c4bcc3886fec6fb Tue 2021-12-21 00:19:16 -03—Tue 2021-12-21 16:04:58 -03
-3 acf95e42b5394df1a10213f706bc2317 Tue 2021-12-21 16:14:57 -03—Tue 2021-12-21 16:41:03 -03
-2 4f481f92fc604deaad3713a8dd9956a1 Tue 2021-12-21 16:42:02 -03—Wed 2021-12-22 23:12:16 -03
-1 4a5f62c960c344bca56057de0557060b Thu 2021-12-23 09:30:35 -03—Thu 2021-12-23 19:54:12 -03
 0 9e4158b72d25468da21a3807f9e5d973 Sun 2021-12-26 20:57:01 -03—Wed 2021-12-29 19:08:00 -03

I have exactly the same issue on Fedora 35 KDE, after logout, the screen goes black.
However, pressing Ctrl + F4 still allows to open up a terminal and Crtl + F2 shows a frozen login screen where nothing can be clicked, but the mouse moves.

Where did you find the KDE bug report? Could you provide a link?

Sure - see KDE issue #374538 “Logout/shutdown/reboot from KDE session hangs system” @

Per @jroc Note 2. - When I let the time timeout it does not return to the login screen. It hangs with a black screen. I can select areas of the black, but can’t get to a local tty or do anything. The power button powers down the system immediately.

I created a new user - and that user was able to logout sucsessfully over several login/logout cycles with varying ammounts of work between login and logout with bot X11 and Wayland sessions.

What can I try to remove in my normal user then to see if I can replicate the new user’s ability?

I am having this issue with KDE spin.
I took the advice of installing GDM and enabling it for startup, rebooting, logging in and then switching back to SDDM. It worked perfectly.

I was able to log out multiple times without issue. Then I decided to customize my “Application Style”. I switched to Fusion, applied, and then tried to log out. Immediately I was stuck again.

I then enabled GDM, rebooted, logged in, switched back to SDDM, and I am able to log out again.

Interestingly enough I was having a hard time logging out of plasma after switching to GDM too.

I wanted to add that if I do a ctrl-alt-F2 while my machine is plagued with the frozen lockout it shows the initial login screen with my password entered (just the dots). When the machine is not experiencing the freezing, ctrl-alt-f2 just shows a black screen.

Do note that switching to GDM also loaded some subset of the gnome DE for me, instead of KDE, but KDE did come back when I switched back to SDDM

  1. Install new DM
  2. systemctl disable oldDM
  3. systemctl enable newDM
  4. reboot
  5. Systemctl disable newDM
  6. systemctl enable oldDM
  7. try logging out

Now I will log out to see if logout is working again… wish me luck?

My first logout worked and I have now logged back in again.

After some system use a second log out trial was mad and was sucsessful.

1 Like