Use dark QT icons for flatpak apps in GNOME?

I am using Gnome with Fedora 39.

I installed Okular PDF reader as a Flatpak.

It uses a dark theme and also dark icons, thus making icons unreadable.

How do I force Okular flatpak to use light icons?

“Fedora 39” I suppose you use GNOME. Install Flatseal from Flathub.

Here you can change environment variables.

Dont know which could work.

I tried these (including the dark variant), but it made no difference.

1 Like

The flatpak KDE runtime pulls in the org.kde.PlatformTheme.QGnomePlatform extension on GNOME, which is what is making the app respect dark mode. It looks like this was meant to fix that issue, but I’m not sure why it doesn’t work: Implement reasonable icon themes fallbacks by grulja · Pull Request #137 · FedoraQt/QGnomePlatform · GitHub

QGnomePlatform is unmaintained now. Flatpak should probably stop installing it (I think Fedora did that already?) You can uninstall and mask it (flatpak mask), but then you won’t get dark mode at all, at least that’s what I see. I don’t understand why the default theme platform doesn’t use the settings portal to get the dark style preference, but I don’t understand Qt in general.

1 Like