Usb speakers not working correctly

I bought a Creative Pebble v3 (usb speakers). I plugged them in Fedora Kde 33 via usb-a and everything works ok (they are recognised as “IEC958”). If I turn off speakers, then turn on them, they don’t work anymore. To hear sound I need to reboot the system, but if I turn off, then turn on, they don’t work. What’s wrong?

Please help me, thanks.

You probably need to go to settings->sound then select them again.

Hi, thanks for you reply. Of course I’ve tried this and kmix: “Digital Output (S/PDIF) Pebble V3 IEC958” is selected but sound doesn’t work. Instead, If I plug headphones, everything works.

There have been several posts recently with similar issues. Try a search for them and you may find the fix. I don’t have a laptop with that issue so have not followed them in detail.

I’ve read some topics here, but none of them is similar to mine: the speaker works every time except when I turn off it, then switch on. It’s not a power related issue, because if i switch intput to bluetooth, it works.

Any other solution? Thanks

Solved! The default Alsamixer muted usb speakers every time I switch them off, than on.

Here are the steps:

1) $ alsamixer
2) press F6 (select sound card)
3) select the sound card (in my case 1 Pebble V3)
4) arrow up to increase volume (was zero for me)
5) press Esc
6) reboot or $ pulseaudio -k
1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.