USB keyboard (and mouse) and also laptop's keyboard taking long time to enable during boot

Hello there!

I just noticed now after some updates that not just my USB keyboard and mouse, but my laptop’s keyboard are taking long time to activate at the passphrase prompt during boot, it was virtually immediatly. Doesn’t look like a kernel thing, I tested with 5.19.x and it also took a while to enable.

Laptop is a Lenovo Legion 5 15IMH05H

Did various tests, like disconnecting, restoring BIOS settings, changing GRUB’s parameters etc, it kept happening. I started thinking that was related to a virtual console service error that I didn’t notice before, that comes before the prompt for the password.
Today I disconnected all USB devices again (USB DAC, USB-C to HDMI cable and USB-c to 4 ports USB HUB), but this time I changed ports because I started thinking was because of may USB-C to HDMI cable. My laptop has three on the back, one being USB-C and one on each side of the laptop. When I removed all USB devices it worked. I re-plugged one by one the devices and it started again. Finally I started plugging one by one and starting the system on each change. When I plugged everything but my U-Phoria UM2 DAC, everything worked. Then I plugged it on the side and everything worked. At the end, I plugged the DAC on the back again, but on the other USB-A port, put the HUB on the one that the DAC was and kept the USB-C to HDMI cable on the only USB-C port.
Everything is working now!
WHY?!?! Have no idea. It worked normally before the way it was.