USB Headset doesn't auto-switch when plugged in on Fedora 36

I upgraded from Fedora 34 to Fedora 36 a few days ago, and now my laptop doesn’t automagically switch audio input/output to the headset when plugged in.

The headset is recognized, in that I can open up Settings → Sound and manually select the headset from the dropdowns for Output and Input there. It just doesn’t automatically switch like it did in Fedora 34.

I am using a Dell XPS 13 from 2020. I don’t think it’s the laptop’s issue, because the headset shows up in lsusb and is available for selection in the Settings->Sound applet and pavucontrol. FWIW it’s a Logitech H390.

Any ideas on how to workaround this (in a way better than doing the manual change after plugging in), or how to debug this?