USB drive attached to router

An USB drive has been attached to the port at the router.
Now, how do I configure the system to be able to recognize and see the drive?

That port is not commonly used to allow the lan to access the drive, but is usually used to store the router log files for later perusal. With most routers it cannot be used as network accessible storage.

What router (brand & model & firmware)?
What exactly are you trying to do?

This is a pretty generic question. What system (router or PC on the lan)? What OS? Is the drive already formatted and mounted? How are you expecting to access it (nfs, cifs, other)?

Note that the more info you provide the better able we will be to evaluate your problem.

yes it can be done but first you need share details like if your router is a rack mounted and what software you are running for pfsence or Opnsence or openwrt on tplink asus router and what firmware you are using and hardware and stuff. i will recommend you to ask in a different forum they provide you better help

If your router has a web-based configuration page, it’s the first thing to look at.
It could be possible that the USB storage is made available via Windows networking. If yes and configured, it can be accessed in Fedora via samba.
My router has an USB connector for a 4G dongle in order to have internet in case of DSL failure. That’s the only application for the USB. Or you can use it only to charge your phone…

This is all new to me, but I have found multiple instructional videos on doing just this. I was able to easily do it on Windows 10, but I’m coming here for help getting it working in Fedora 36.

I have a Netgear N600 router with one USB port. Netgear has this “readyshare” option that lets you use a device plugged into it as a simple sort of NAS, so that part was easy. I plugged in an external HDD with its own power supply. I went to my router’s setup page and edited the name of the shared drive/folder and gave it a password. In Windows, all I had to do was type in the path set up by my router into Windows Explorer (for me, \largedrive\USB_Storage). Then I was able to right click and map it as a network drive. Only (potentially big) downside is that I had to enable SMB v1.0 in Windows features, since that’s all my router supports.

I feel like this shouldn’t be difficult in Fedora! First thing I tried after googling a little was typing the default IP address into the “Connect to Server” field in “Other locations” in Files. That found the USB_Storage folder, but couldn’t open it. I assume perhaps because there was no option that popped up for the username and password. Next, I pieced together some directions in the terminal from other websites.

  • I created a folder called LargeDriveAccess to point to.
  • I added //*username*/LargeDriveAccess cifs rw,user,noauto 0 0 to the fstab file (I tried a couple different versions of this)
  • I ran sudo mount -t cifs -o *routershareusername*/*routersharepassword*// /home/*username*/LargeDriveAccess -o vers=1.0 (I tried a couple different versions of this, too)

This then prompts me Password for root@// which is where I run into problems. I try the password for the shared folder, the password for my wifi, no password (just hit enter), 0, etc. and I always get the error:

mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

Interestingly, I can now see LargeDriveAccess in my networks, but when I double click on it, I get the error “This program is not installed setuid root- “user” CIFS mounts not supported.”

Under my networks, I also now have Windows Network > WORKGROUP > LARGEDRIVE >USB_Storage, which I think is from another command I tried. But clicking on it results in the error “Unable to access location. Failed to mount Windows share: Software caused connection abort.”

Anyone know what parts of this I’ve gotten wrong? Also, why isn’t this a simple operation through a GUI?

Maybe I should be trying smbfs instead of cifs because of my outdated router needing smb 1.0?

By default fedora has disabled smb v 1.0 so if that is all the router supports you will be forced to alter the smb config to enable v 1.0 before you can access that device.

1 Like

Thanks for replying.

Yeah, rather than try to figure out exactly how to make it work, I decided I wasn’t comfortable using smb 1.0, so I gave up on trying to access a hard drive this way. I’ll just have to save up for a small NAS.