USB DAC not listed under devices if powered off when system starts

Hi. A week or two ago some update changed a behavior: my Fiio K5 pro external (USB) headphone amplifier + DAC , which has external power and a power knob, is not detected by the sound system (not listed under Audio Devices in Plasma) if Fedora starts when the K5 is turned off (and then turned on after Fedora has started).

Fedora used to show a notification that a new audio device was in use when I turned it on after Fedora had started, now it doesn’t. lsusb sees it when it is on and pw-cli , list-objects lists

id 47, type PipeWire:Interface:Device/3 = "14" = "32"
	device.api = "alsa"
	device.description = "FiiO K5 Pro" = "alsa_card.usb-GuangZhou_FiiO_Electronics_Co._Ltd_FiiO_K5_Pro-00"
	device.nick = "FiiO K5 Pro"
	media.class = "Audio/Device"

however it isn’t listed under Audio devices in Plasma and it cannot be selected for audio out (and nothing is played through it).

If the K5 is turned on when Fedora starts it works well and I can thereafter turn the K5 on and off, while Feodra remains running, and the notification appears as prior and everything works as expected. So this isn’t critical but merely an annoyance. What can I do to alleviate it, if anything?

This probably has to do with the new nature of pipewire and should be reported to the pipewire developers as an issue.

I’d rather have more to present before finding their issue tracker and creating a new issue, therefore I examined the Fedora wiki on Pipewire. Longer story short: under Plasma system settings : Audio - configure, the K5 Pro was set to profile Analog Stereo Output (it always has and it worked in the past even when the K5 was turned off as Fedora started), however with that profile it doesn’t appear as an outdevice under system settings : audio. (unless Fedora started when the K5 was switched on). It appears and starts working if I select the (new?) profile “Pro” however. So with the “Pro” profile the K5 Pro appears as “FiiO K5 Pro Pro” :slight_smile: in the volume out field and it works even when switched on after Fedora has started.

(As I troubleshot I noted that “aplay -L” showed the K5 Pro with profile “Pro” before I tried setting it to that profile in the system settings)