Upgraded Nvidia GPU hardware and now flatpak steam games borked


As per title, I’ve installed a new gpu. I tried to just insert it assuming that the existing Nvidia drivers which worked fine would just take over the reigns, however it doesn’t work.

Games are able to start fine but once I start them, usually via Steam Flatpak, they get into initial menus and such but either run at 1fps or never reach the game at all. My 5800x is usually pinned at 85-100% utilisation on all cores. The GPU on the other hand is barely being touched, and I’m not noticing any flatpak apps appearing in the memory section of nvidia-smi, only normal packaged apps like firefox.

I’ve tried to remove all nvidia drivers and reinstall them all using the below commands but i’ve still got exactly the same issue.

This is my Inxi Output

sudo dnf remove \*nvidia\*
sudo dnf install akmod-nvidia xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs xorg-x11-drv-nvidia-cuda

This is my nvidia-smi output:

~/ nvidia-smi
Tue Jan 31 22:59:51 2023
| NVIDIA-SMI 525.85.05    Driver Version: 525.85.05    CUDA Version: 12.0     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:2D:00.0  On |                  N/A |
| 32%   44C    P0   112W / 420W |   1194MiB / 24576MiB |      5%      Default |
|                               |                      |                  N/A |

| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      1792      G   /usr/libexec/Xorg                 788MiB |
|    0   N/A  N/A      2944      G   alacritty                          12MiB |
|    0   N/A  N/A      4210      G   alacritty                          13MiB |
|    0   N/A  N/A      8501      G   alacritty                          12MiB |
|    0   N/A  N/A     10220      G   /usr/lib64/firefox/firefox        364MiB |

These are the nvidia packages I have installed:

~/ dnf list installed | grep nvidia
akmod-nvidia.x86_64                                  3:525.85.05-1.fc37                   @rpmfusion-nonfree-updates
kmod-nvidia-6.1.8-200.fc37.x86_64.x86_64             3:525.85.05-1.fc37                   @@commandline
nvidia-persistenced.x86_64                           3:525.85.05-1.fc37                   @rpmfusion-nonfree-updates
nvidia-settings.x86_64                               3:525.85.05-1.fc37                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                           3:525.85.05-1.fc37                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64                      3:525.85.05-1.fc37                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.i686                   3:525.85.05-1.fc37                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                 3:525.85.05-1.fc37                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                   3:525.85.05-1.fc37                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i686                        3:525.85.05-1.fc37                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                      3:525.85.05-1.fc37                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64                     3:525.85.05-1.fc37                   @rpmfusion-nonfree-updates

I’m wondering if It’s related to flatpak and steam because I’ve got firefox installed as a non flatpak and that shows up in the GPU memory when running nvidia-smi, however flatpaks don’t. I ran a flatpak remove --unused and it came up with this traumatising list, not sure if it’s going to break any flatpak apps if I run it, although I’ve got snapshots running and should just try it!

FYI, my flatpak nvidia drivers, if it helps…

~/ flatpak list|grep -i nvidia
nvidia-470-141-03	org.freedesktop.Platform.GL.nvidia-470-141-03		1.4	system
nvidia-515-65-01	org.freedesktop.Platform.GL.nvidia-515-65-01		1.4	system
nvidia-515-76	org.freedesktop.Platform.GL.nvidia-515-76		1.4	system
nvidia-520-56-06	org.freedesktop.Platform.GL.nvidia-520-56-06		1.4	system
nvidia-525-60-11	org.freedesktop.Platform.GL.nvidia-525-60-11		1.4	system
nvidia-525-78-01	org.freedesktop.Platform.GL.nvidia-525-78-01		1.4	system
nvidia-525-85-05	org.freedesktop.Platform.GL.nvidia-525-85-05		1.4	system
nvidia-470-141-03	org.freedesktop.Platform.GL32.nvidia-470-141-03		1.4	system
nvidia-515-65-01	org.freedesktop.Platform.GL32.nvidia-515-65-01		1.4	system
nvidia-515-76	org.freedesktop.Platform.GL32.nvidia-515-76		1.4	system
nvidia-520-56-06	org.freedesktop.Platform.GL32.nvidia-520-56-06		1.4	system
nvidia-525-60-11	org.freedesktop.Platform.GL32.nvidia-525-60-11		1.4	system
nvidia-525-78-01	org.freedesktop.Platform.GL32.nvidia-525-78-01		1.4	system
nvidia-525-85-05	org.freedesktop.Platform.GL32.nvidia-525-85-05		1.4	system

Any ideas?


You will need to reinstall the nvidia-gpu-firmware package that would have been removed with your removal of ‘nvidia’. That probably can be done with dnf reinstall linux-firmware. If that does not get the nvidia-gpu-firmware package then dnf install nvidia-gpu-firmware surely should.

We also would like to see the output of inxi -Fzxx and lsmod | grep nvidia.

You can remove all those flatpak nvidia runtime packages except the ones having nvidia-525-85-05 in the name. Those are required for the currently installed nvidia drivers.

Yes, you can also run flatpak uninstall --unused as that should not remove anything that is required by the system and installed flatpaks. Unfortunately it will not remove the old and unused paks related to nvidia.


Hi Jeff!

Always appreciate your replies.

I’ve added the firmware, restarted steam and boom! It’s working like a dream!

Flatpak issue resolved too - thank you!

Here are the outputs requested:

~/ inxi -Fzxx
  Kernel: 6.1.8-200.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-25.fc37 Desktop: i3 v: 4.22 dm: LightDM Distro: Fedora release 37
    (Thirty Seven)
  Type: Desktop Mobo: Micro-Star model: MAG X570 TOMAHAWK WIFI (MS-7C84)
    v: 1.0 serial: <superuser required> UEFI: American Megatrends LLC. v: 1.B2
    date: 08/10/2022
  Info: 8-core model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3
    rev: 0 cache: L1: 512 KiB L2: 4 MiB L3: 32 MiB
  Speed (MHz): avg: 2312 high: 2795 min/max: 2200/4850 boost: enabled cores:
    1: 2200 2: 2200 3: 2200 4: 2433 5: 2252 6: 2200 7: 2437 8: 2200 9: 2200
    10: 2200 11: 2243 12: 2795 13: 2377 14: 2670 15: 2200 16: 2200
    bogomips: 121607
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA GA102 [GeForce RTX 3090] vendor: Micro-Star MSI
    driver: nvidia v: 525.85.05 arch: Ampere pcie: speed: 2.5 GT/s lanes: 16
    ports: active: none off: DP-1,DP-2,DP-3 empty: HDMI-A-1 bus-ID: 2d:00.0
    chip-ID: 10de:2204
  Device-2: Generic NexiGo N660P FHD Webcam type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-1:2 chip-ID: 660a:3443
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.7 driver: X:
    loaded: nvidia unloaded: fbdev,modesetting,nouveau,vesa alternate: nv
    gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 6400x4320 s-dpi: 161
  Monitor-1: DP-1 mapped: DP-0 note: disabled pos: bottom-r
    model: LG (GoldStar) Ultra HD res: 3840x2160 dpi: 163 diag: 690mm (27.2")
  Monitor-2: DP-2 note: disabled pos: primary,top-left
    model: Asus ROG PG278Q res: 2560x1440 dpi: 109 diag: 686mm (27")
  Monitor-3: DP-3 mapped: DP-4 note: disabled model: LG (GoldStar) Ultra HD
    res: 2560x1440 dpi: 163 diag: 690mm (27.2")
  API: OpenGL v: 4.6.0 NVIDIA 525.85.05 renderer: NVIDIA GeForce RTX
    3090/PCIe/SSE2 direct render: Yes
  Device-1: NVIDIA GA102 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 1-1:2 chip-ID: 660a:3443 pcie:
    speed: 16 GT/s lanes: 16 bus-ID: 2d:00.1 chip-ID: 10de:1aef
  Device-2: Generic NexiGo N660P FHD Webcam type: USB
    driver: snd-usb-audio,uvcvideo
  Device-3: XMOS iFi (by AMR) HD USB Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-3:2 chip-ID: 20b1:3008
  Sound API: ALSA v: k6.1.8-200.fc37.x86_64 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
    v: kernel pcie: speed: 5 GT/s lanes: 1 port: f000 bus-ID: 26:00.0
    chip-ID: 10ec:8125
  IF: enp38s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:3
    chip-ID: 8087:0029
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 8.12 TiB used: 5.78 TiB (71.2%)
  ID-1: /dev/nvme0n1 vendor: A-Data model: SX8200PNP size: 953.87 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 30.9 C
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 960 EVO 250GB
    size: 232.89 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 28.9 C
  ID-3: /dev/sda vendor: Samsung model: HD401LJ size: 372.61 GiB
    speed: 3.0 Gb/s serial: <filter>
  ID-4: /dev/sdb vendor: Western Digital model: WD10EAVS-00D7B0
    size: 931.51 GiB speed: 3.0 Gb/s serial: <filter>
  ID-5: /dev/sdc vendor: Seagate model: ST6000DM003-2CY186 size: 5.46 TiB
    speed: 6.0 Gb/s serial: <filter>
  ID-6: /dev/sdd vendor: Samsung model: SSD 840 EVO 250GB size: 232.89 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-1: / size: 199.3 GiB used: 127.24 GiB (63.8%) fs: btrfs
    dev: /dev/nvme1n1p3
  ID-2: /boot size: 973.4 MiB used: 268.8 MiB (27.6%) fs: ext4
    dev: /dev/nvme1n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/nvme1n1p1
  ID-4: /home size: 953.87 GiB used: 780.47 GiB (81.8%) fs: btrfs
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: zram size: 8 GiB used: 1.91 GiB (23.9%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 32 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme1n1p4
  System Temperatures: cpu: 30.0 C mobo: 29.0 C gpu: nvidia temp: 42 C
  Fan Speeds (RPM): fan-1: 0 fan-2: 2093 fan-3: 1136 fan-4: 1133 fan-5: 614
    fan-6: 0 fan-7: 0 gpu: nvidia fan: 0%
  Processes: 554 Uptime: 11h 18m Memory: 31.27 GiB used: 10.58 GiB (33.8%)
  Init: systemd v: 251 target: graphical (5) default: graphical Compilers:
  gcc: 12.2.1 Packages: pm: rpm pkgs: N/A note: see --rpm pm: flatpak pkgs: 93
  Shell: Zsh v: 5.9 running-in: alacritty inxi: 3.3.24
(base) █▓▒░sunil@SUNIL-Fed█▓▒░ Wed Feb 01 09:24:58am
~/ lsmod|grep nvidia
nvidia_drm             73728  12
nvidia_modeset       1220608  13 nvidia_drm
nvidia_uvm           2904064  0
nvidia              56406016  698 nvidia_uvm,nvidia_modeset
video                  65536  1 nvidia_modeset

Glad I was able to assist.
Please mark the appropriate post as solution so others may find it when they are searching.

1 Like