Upgrade to Fedora 31 and AMDGPU driver not loading

Hi there folks,

My Fedora 30 system was working fine as far as display goes, but the graphics acceleration wasn’t working (fallback to llvmpipe) so I updated to 31 and hoped for a fix, after reading about changes to amdgpu and mesa between 30 and 31. Booting Fedora 31 with 5.5.6-201.fc31 doesn’t load the amdgpu driver at all, falling back to 1024x768 resolution. Interestingly, booting the previous kernel 5.5.6-100.fc30 brings back amdgpu with full acceleration(!).

Any idea what could be happening and how to proceed from here?

Thanks in advance,

PS: The system is Intel(R) Core™ i7-8700K CPU @ 3.70GHz, on ASUS Z730-Pro TUF Gaming mobo, 64GB RAM, running AMD GPU Radeon RX 5500 XT 8GB.

[Edit:] Perhaps it’s useful to point out the same happens when booting a Live Fedora 31 from a flash drive, to discard something going wrong from the dnf-upgrade process.

# Hi.  What is "Kernel module in use" for this GPU?
lspci -v


The kernel module in use with kernel 5.5.6-100.fc30 is amdgpu.

$ lspci -v

03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 14 [Radeon RX 5500/5500M / Pro 5500M] (rev c5) (prog-if 00 [VGA controller])
Subsystem: XFX Pine Group Inc. Device 5501
Flags: bus master, fast devsel, latency 0, IRQ 140
Memory at c0000000 (64-bit, prefetchable) [size=256M]
Memory at d0000000 (64-bit, prefetchable) [size=2M]
I/O ports at e000 [size=256]
Memory at dfb00000 (32-bit, non-prefetchable) [size=512K]
Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: amdgpu
Kernel modules: amdgpu

$ lsmod | grep amd
amdgpu               5308416  47
amd_iommu_v2           20480  1 amdgpu
gpu_sched              36864  1 amdgpu
i2c_algo_bit           16384  1 amdgpu
ttm                   122880  1 amdgpu
drm_kms_helper        233472  1 amdgpu
drm                   585728  12 gpu_sched,drm_kms_helper,amdgpu,ttm

With the kernel 5.5.6-201.fc31, there’s no amdgpu module loaded.

Thanks for your response,

Hello again,

I’ve tried the unreleased Fedora 32 Live Workstation with interesting results. The video comes back in full resolution with acceleration, properly loading the amdgpu driver. Interestingly though, the amdgpu throws an error message during boot, apparently without ill effect:

amdgpu 0000:03:00.0: Direct firmware load for amdgpu/navi14_ta.bin failed with error -2
amdgpu 0000:03:00.0: psp v11.0: Failed to load firmware "amdgpu/navi14_ta.bin"

This error message is not present on Fedora 30 or 31.

So it seems something goes wrong with Fedora 31 using the last two kernels (5.5.6-201, 5.5.8-200), since the amdgpu driver or the drm driver are not loaded during boot.

I’m attaching all boot logs in case a helpful soul can bring some light to this mystery.

Thanks in advance for your interest.

1 Like


I’ve found the reason Fedora 31 doesn’t load the amdgpu module. As embarrassing as it may be, the amdgpu module was blacklisted in /etc/modprobe.d/amdgpu, a file I had added while debugging Fedora 30 acceleration. The funny part was that both Fedora 30 and F31 with F30’s kernel ignored the blacklisting, so they were still loading the amdgpu module. And the question still stands why Fedora 31 Live Workstation behaved as if it was blacklisted too.
So mystery solved. All good in Fedora-land.

Thanks for reading!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.