Upgrade issue when updating to F36: problem with installed package mutter3.38-libs-3.38.6-1.fc35.x86_64

I’m trying to upgrade from f35 to f36. Using ‘sudo dnf system-upgrade download --releasever=36’ I get the following errors:

Fedora 36 openh264 (From Cisco) - x86_64                                   392  B/s | 271  B     00:00    
Errors during downloading metadata for repository 'fedora-cisco-openh264':
  - Status code: 404 for https://codecs.fedoraproject.org/openh264/36/x86_64/repodata/repomd.xml (IP:
Error: Failed to download metadata for repo 'fedora-cisco-openh264': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

 Problem: package mutter3.38-libs-3.38.6-1.fc35.x86_64 requires libwacom.so.2()(64bit), but none of the providers can be installed
  - package mutter3.38-libs-3.38.6-1.fc35.x86_64 requires libwacom.so.2(LIBWACOM_0.33)(64bit), but none of the providers can be installed
  - libwacom-1.12.1-2.fc35.x86_64 does not belong to a distupgrade repository
  - problem with installed package mutter3.38-libs-3.38.6-1.fc35.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

This makes it sound like the Wacom libraries are not part of the new version. Giving up the tablet is not an option.

I tried adding “–skip-broken” it didn’t help.

Any suggestions?

1 Like
$ rpm -qa \*wacom\*

so wacom is certainly supported in F36. I also see it in settings:

Not sure of the dependency error here. Could you please double-check that your F35 installation is completely up to date? Could you also please list what repositories you have enabled:

sudo dnf repolist

I’ve checked updates 3+ times: through Software, DNFDragora, and from the command line.

repositories are:

repo id    - repo name
fedora        - Fedora 35 - x86_64
fedora-cisco-openh264   -  Fedora 35 openh264 (From Cisco) - x86_64
fedora-modular   - Fedora Modular 35 - x86_64
google-chrome    -  google-chrome
phracek-PyCharm   -  Copr repo for PyCharm owned by phracek
rpmfusion-free       - RPM Fusion for Fedora 35 - Free
rpmfusion-free-updates  -   RPM Fusion for Fedora 35 - Free - Updates
rpmfusion-nonfree   - RPM Fusion for Fedora 35 - Nonfree
rpmfusion-nonfree-nvidia-driver - RPM Fusion for Fedora 35 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam  - RPM Fusion for Fedora 35 - Nonfree - Steam
rpmfusion-nonfree-updates   - RPM Fusion for Fedora 35 - Nonfree - Updates
updates     -  Fedora 35 - x86_64 - Updates
updates-modular - Fedora Modular 35 - x86_64 - Updates

The Wacom tablet is working fine under f35

1 Like

This appears to be the package causing issues. It was a “compat” package which was probably needed by some other tools at some point but it has been retired now. Could you please check what other mutter packages you have installed? You should just have the non-compat mutter package, and in that case, we should be able to remove this mutter3.38 package to fix your issue:

rpm -qa \*mutter\*

Package creating the issue is mutter3.38:


The package Gnome uses normally is just mutter (without the 3.38):


Both mutter and mutter3.38-libs were installed. I removed mutter3.38-libs and the upgrade completed.

now… booting to kernel 5.17.12fc36 gives an error saying ‘Nvidia kernel is missing, reverting to nouveau’ and gives me a black screen. But, the Nvidia kernel 5.17.12-300.fc36 is installed and nouveau is not.

Booting into kernel 5.17.12fc35 seems to work - at least I have video

1 Like

I found another thread on the Nvidia error which advised removing and re-installing all of Nvidia (dnf remove *nvidia* ; dnf install akmod-nvidia)

It seems to be working now.

Thanks for your help

1 Like

That’s good to hear.

Yes, since the upgrade process also updates the kernel, a new Nvidia kmod needs to be built. However, it looks like the upgrade process doesn’t quite wait for the kmod build to finish, and so there isn’t an Nvidia driver upon upgrade. As you noted, uninstalling and re-installing the akmod-package gets the Nvidia driver re-built and that fixes things.