Upgrade-in-place from 35 to 36 failed, switched fs from ext4 to btrfs


Previously running Fedora WS 35, which was an upgrade-in-place from Fedora WS 34 with a custom install to use ext4 instead of btrfs (I’ve had lots of problems with btrfs in the past, resulting in multiple reinstalls). Tried upgrade-in-place to Fedora WS 36 last week, following all normal steps. Computer rebooted, but came back up in WS 35 instead. I didn’t realize it for a day or two, then started having problems with ‘sudo dnf update’ not working due to dnf directory being read-only. Rebooting fixed the issue a couple times, then programs (Chrome, Firefox, VSC, Slack) starting locking up. Research showed I was still running WS 35 and running dmsg shows lots of system.journal and user-1000.journal ‘file corrupted…rotating’ messages, each followed by 3 ‘failed to rotate…file system read-only’ messages and 1 ‘failed to write entry…despite vacuuming’ message. Checked my hard drives…had 2 1TB ssd drives and 2 2TB ssd drives, all running ext4. Now both 1TB drives and one of the 2TB drives are running btrfs, labeled ‘fedora_localhost-live’. At this point I have no idea what state my machine is in…really hoping not to have to start from scratch (again!), but starting to become disillusioned with Fedora. Any help would be greatly appreciated.

How did you do the upgrade? Please show the commands used. (emphasis above mine)

If you used the standard dnf upgrade --refresh step followed by the dnf system-upgrade --releasever=36 download and the dnf system-upgrade reboot steps then it would not have switched between ext4 and btrfs. That type file system switch just does not happen with a standard upgrade.

Same for using the gnome-software app to do the version upgrade. A file system switch of that sort just does not happen.

Thanks for responding , Jeff. You correctly listed the steps I took for the upgrade. I went back and rechecked fstab (dated December of 2021) …both /root and /home are using btrfs. In one of my many reinstalls I must have given up trying to force ext4 and just let the install use it’s defaults. So, one mystery solved. However, still have the issues of the upgrade not completing and btrfs reporting corrupt journals. With a journaling file system like btrfs can the system be rolled back somehow to a known good state? Don’t know what my next steps should be.