Updating kernel causes big troubles in the system

Hi guys!

Yesterday I was trying to install VirtualBox in my PC. I got an error about kernel not having the correct drivers and stuff, I ended installing “kernel-devel” and “kernel-header” also running sudo dnf update and rebooting the system.

After the reboot I actually got VirtualBox and the VM running perfectly. After I reboot my PC again the problems started to appear:

  1. I have 2 monitors (1 HDMI, 1DP that actually has a DP-to-HDMI inserted). The DP connector just stopped working and did not recognize the 2nd monitor after that. I checked if was the monitor by just connecting each one only to the HDMI and both worked. I am pretty sure that the problem is the adaptor not being recognized. When I run xrandr, outputs:

Screen 0: minimum 16 x 16, current 1360 x 768, maximum 32767 x 32767
XWAYLAND0 connected 1366x768+0+0 (normal left inverted right x axis y axis) 359mm x 203mm
1366x768 59.80*+
1024x768 59.92
800x600 59.86
640x480 59.38
320x240 59.52
720x480 59.71
640x400 59.95
320x200 58.96
1280x720 59.86
1024x576 59.90
864x486 59.92
720x400 59.55
640x350 59.77

It actually do not even recognize the DP port. Also, when I run inxi -Fxz, outputs:

Device-1: AMD Navi 24 [Radeon RX 6400/6500 XT/6500M]
vendor: Tul / PowerColor driver: N/A arch: RDNA-2 bus-ID: 06:00.0
Display: wayland server: X.Org v: 22.1.8 with: Xwayland v: 22.1.8
compositor: gnome-shell driver: X: loaded: modesetting,radeon,vesa
unloaded: fbdev dri: swrast gpu: N/A resolution: 1366x768~60Hz
API: OpenGL v: 4.5 Mesa 22.3.5 renderer: llvmpipe (LLVM 15.0.7 256 bits)
direct-render: Yes
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: N/A bus-ID: 06:00.1
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK driver: N/A
bus-ID: 0d:00.4
Sound Server-1: PulseAudio v: 16.1 running: yes
Sound Server-2: PipeWire v: 0.3.66 running: yes

I also noted that some of the features of Fedora disappear, such as: hot corner transition is absent (when I invoke hot corners it abruptly shows all windows, before this problem hot corners had a nice transition to show all windows).

On top of this, the audio of my monitor also stopped working. The settings menu only shows “Dummy output”. To make it worse, seems that the system is not recognizing my graphics card (RX6500 XT): the “Graphics” category in the settings menu (“About”) only shows “Software Rendering” instead of “RX 6500 …”

I already have tried to return to a previous kernel version. To fix the audio I have also tried some of the solutions here in AskFedora but none of them works.

It would be nice if someone could guide me or tell me how to fix this problem!


Welcome to the Fedoraproject @alejandrogzi

It looks like you packed to many problems in one request. Are this problems within the Virtualbox or on the host OS?

Have you tried to start up with xorg instead of wayland to see if it has the same issue.

Hi, guys!

Thank you for your responses!

Yes, it all started with the second monitor not being detected but the problems just kept appearing after that. I uninstalled VirtualBox after that. The problems are on the host OS.

Yes! Actually I have always used xorg. I tried to use Wayland this time to see if it had the same issue.

Yesterday I tried to clean my PC unplug the graphics card, plugged again, uninstall drivers and install them again, nothing works.

Any other ideas?


Perhaps it is not the kernel upgrade, but rather the xorg upgrade. Try rolling back to previous version with dnf and see what happens.