Updating from fedora 25 to any fedora fails

I cant upgrade from fedora 25 to any fedora. I tried DNF method, from fedora 25 to fedora 27,31,32…
But after rebooting, it says upgrading, and then again reboot into the old fedora 25. Just fedup with it.
Also if I download the iso image and make a bootable pendrive, from that I cant upgrade, I have to do a fresh installation.
Why fedora make it soo difficult to upgrade. And we dnt want any new version every 2 months. Kindly suggest why fedora after upgrading and rebooting into the old fedora

Hi @bipulrr, and welcome to the community. If you have a moment, please take a look at the start-here category.

Fedora 25 has been discontinued for some time, so that update can’t work - Fedora generally supports upgrades across 2 releases. At this point, the repository mirrors won’t even have packages for F25. You could possibly use the Fedora Archives mirror, but at this point, a fresh install of Fedora 32 will be far simpler. You can do so without messing with your /home data, and reinstalling your software can also be done in a fairly automated fashion.

Fedora releases a new version roughly every 6 months and supports each release for about 13, so you can generally get away with one distro upgrade per year. If that is too quick for your tastes, but you like Fedora generally, you could take a look at CentOS, which builds from the same base but iterates much more slowly.


Dear sir,
Really thanks for the reply. Can u guide me or send an appropriate link to reinstall fedora 32, keeping /home as it is…

Does your /home reside on a separate partition (It should appear in the output of lsblk or mount if so)?

Yes sir, the /home is in separate partition in my fedora 25.

Good, that makes things fairly simple. Still, it is advisable to create a backup of your data before proceeding.

  1. If you have made any modifications to config files outside your home directory (stuff in /etc being the most likely candidate), backup those files. Additionally, you can use dnf history userinstalled to generate a list of all software you installed manually, to help you with reinstalling stuff after the update.

  2. When you run the Fedora 32 installer, at the Installation target step, select Custom instead of Automatic partitioning. In the following tool you’ll see all your existing partitions, simply assign them to the same mount points, and select Reformat for the system partitions (/, swap and likely boot), but not for /home. Proceed with the installation as usual.

  3. On first boot, use the same username as before & your previous home directory should be automatically reused.

OK, so you have a fairly standard Fedora partition layout, so keep /home, reformat /, /boot and swap.

Here are some screenshots from the Fedora 32 installer:

  1. Select Custom as Storage Configuration and hit Done

    The following dialog opens:
  2. Change LVM to Standard partition
  3. Select /home partition (sda8 in your case). They might be listed under Unknown on your system.
  4. Set mountpoint to /home
  5. Make sure Reformat is unchecked
  6. Hit Update Settings
  7. Repeat for /, /boot, and swap, but selecting Reformat instead of leaving it unchecked. swap requires no mountpoint.

Oh wow… Now it is crystal clear… Thanks a lot… It will really helped me a lot and in future i will regularly upgrade to new fedora.

Really appreciate it. I successfully installed it keeping my /home intact. Very very thankful to you.
One more thing, what is the root user name?
Bcoz the old root user now not working.

1 Like

I’m not 100% sure, but I think by default the root account is disabled on recent fedora versions, it is recommended to use sudo <command> instead of actually logging into the root account. You can also get a root shell using sudo -i or sudo -s.

If you absolutely need to have a log-in-able root account, setting a password for it should be enough (sudo passwd root).

Hello sir,
Really thanks for your help and everything works fine.
I am using huion tablet 1060 plus, Though it is detected in fedora 32, but I cant configure the HOTKEYS of the tablet.
So I am installing DIGIMEND drivers for the graphic tablet. (sudo make dkms_install)
But it is showing error
“Your kernel headers for kernel 5.6.6-300.fc32.x86_64 cannot be found at
/lib/modules/5.6.6-300.fc32.x86_64/build or /lib/modules/5.6.6-300.fc32.x86_64/source.
You can use the --kernelsourcedir option to tell DKMS where it’s located.
make: *** [Makefile:101: dkms_modules_install] Error 1”
Though I update the kernel to 5.7.7…
but there also showing the same error…
Any solution please.


Have you installed the kernel-headers:

sudo dnf install kernel-headers

If that doesn’t help, please provide a link to the DIGIMEND drivers

Thanks Tom.

Make sure you reboot to actually use the latest kernel.

Now its working fine after in use dnf upgrade and install the new kernel today.
Thanks a lot for your help…

1 Like

Respected sir,
Thanks for the reply… now everything works fine. this is the link for the digimend

Huion tablet is recognised

xsetwacom --list
ID 256c:006e Pen stylus id: 10 type: STYLUS
HID 256c:006e Pad pad id: 11 type: PAD

The only problem is now the tablet area doesnt recognize the whole area of the laptop screen.
How to fix it?


From a quick google, looks like with xsetwacom --set:

xsetwacom --set *Device from list* MapToOutput *screen resolution*

No familiar with device myself, so don’t think I can be much help with this.

Thanks Tom.

Ok great… I know the device name… I will look into it and let you know the if I get some solution.

Respected sir,

I got the solution. Now the tablet (Huion 1060Plus) working fine. Its detected by “xsetwacom --list” command.
Following is the procedure

  1. Go to the following website and download the following zip file for your tablet https://digimend.github.io/drivers/digimend/tablets/
  2. Update the kernel. Mine didnt work in 5.6.6 but after Updating 5.7.7 it worked.
  3. Follow the instructions to install
  4. In order to configure the Express Keys and use the whole screen of your laptop/Monitor to work refer the Huion1060Plus.sh file attached, got from youtube link https://www.youtube.com/watch?v=zxFKMRgDr-k
  5. Is it possible to make a GUI in next update/upgrade of fedora…?

(Attachment Huion1060Plus.sh is missing)

1 Like

GNOME has the Wacom Graphics Tablet GUI as part of the control center, there are some additional configuration utilities listed here. I don’t know if any of them can calibrate the tablet to the screen though.
Beyond that, well, somebody would have to write a GUI.