Updated to fedora 35 and lost audio, but only in Zoom

I have 2 PCs. An Acer laptop and a desktop. Updated both from fedora 34 to 35. Desktop - no problem. Laptop that I have used for Zoom meetings - no audio for Zoom now. Everything else in audio seems OK, youtube and such. When I join a Zoom meeting I have always gotten a volume slider added to Setup just for Zoom. That doesn’t help anymore. It worked in fedora 34. I can use the speaker test buttons in the Zoom slider and hear the test result. I removed and reinstalled Zoom - no improvement. I see other people have had problems with audio not working at all in fedora 35, but my problem is just Zoom. I did
systemctl --user status pipewire pipewire-pulse
and both are shown as active and running.
Any sugestions?

Welcome to ask :fedora:

What about wireplumber? Is this ok too?

systemctl --user status wireplumber*

Wireplumber is new on F35 > Releases/35/ChangeSet - Fedora Project Wiki see point 2.17

If everything is fine in with wireplumber, please check on the laptop if mute and un-mute the output helps. This is a problem i noticed the last few days.

I recognized my problem also on zoom. I connected to a meeting and there was no sound. But in reality the volume was just very low.

systemctl --user statuw wireplumber shows it is active and running.
I muted and un-muted the zoom sliders with no effect. Multiple times. The other sliders work as expected.
I assume that zoom is treated differently in sound settings - since it gets it’s own separate volume sliders - but I am not familiar with how that works. Seems zoom has a unique failure.

My desktop also was upgraded from fedora 34 to 35 and has no audio problem, Different hardware.

Posts I have seen that were similar usually found the fix within zoom itself with either muting or volume settings.

The only volume setting or mute that I know of show up in fedora > settings > sound
where a couple of volume sliders are added when I join a zoom meeting . Those do not solve my problem. I do not see any relevant audio settings in my zoom profile. Are we talking about the same things?

Under zoom settings you select the input and output devices. There, on my laptop I see 3 inputs for the microphone, and 4 outputs for the speaker. I actually can hear sound from my laptop if I select “same as system”, “Built-in Audio Analog Stereo”, (both use the laptop speakers) or “headphone”. There is one output that does not produce sound, HDMI via my GPU (monitor has no speakers).

My laptop with fedora 35 has pipewire and wireplumber for audio and they both work. I can say that the first use of zoom after the upgrade from 34 to 34 required that I go into the settings again and select both the input and output devices new because for some reason the settings with 34 were not retained properly. I suspect it may have to do with adding wireplumber into the mix but cannot be sure.

Have you tried going into the settings and selecting the speaker output again and tested it?
Have you done the same for the microphone input?

1 Like

I have the same problem with Zoom. When launched, it crashes the pipewire audio server and then I need to restart it manually. After a restart Zoom still does not work in terms of audio.

Please include the versions of zoom. Newest one to download is Version 5.8.6 (739)

Yes I have tried going into the settings and selecting the speaker output and tested it. No help there.

1 Like

I am using version 5.8.6 (739) as a flatpak application. I also tried the standard version from the Zoom web site but the result was the same. The audio server crashes.

Exactly what I was going to suggest. I had this exact same issue all year with conference calls. Then just last week I realised that Linux (only on zoom) randomly switches the channels of the audio inputs and outputs.

So yes @billdurr please check the input and outputs on zoom and that they match the gnome settings, and I have to do this each time i login to the zoom (rpm) client otherwise no audio.

Another problem with Zoom on Wayland is that when using NVIDIA the window is not rendered properly and it is black and empty with no contents. This can be fixed by modifying the configuration zoomus.conf file and specifying:


but a problem remains: the drop-down menus of this application are not rendered properly and they are black.

BTW, Skype has the same problem which can be fixed by running it with the additional argument:


Electron has several issues.

Disabling the gpu sandbox on Skype could open the door to security threats (especially since Skype is owned by MS). I would not recommend removing the sandbox for skype. Simply switch to Xorg server whenever you need to skype its quite straightforward.

Removing sandboxing to the GPU is dangerous and it would be better to run skype through a good browser instead until skype fixes it or switch display servers

On this laptop I only have one choice for input, whether I am in a zoom meeting or not:
internal mic - built in audio
And only one choice for output - if I don’t have an external speaker plugged in:
speakers -built-in audio
If I plug in an external speaker I only have one choice:
headphones - built in audio

And checking status with systemctl during a zoom session I see that pipewire, pipewire-pulse and wireplumber are all active and running.