Updated to 40, no more nvidia driver, slow games

Hello. Everything worked fine after the update from 39 to 40 (KDE, workstation). I have installed plasma-workspace-x11 and recreated X11 config file, because my steam games are working terribly slow since the update. I have run vkcube, and it says

Selected GPU 0: llvmpipe (LLVM 18.1.6, 256 bits), type: Cpu

When I run nvidia-smi, it says

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Running modinfo -F version nvidia I get

modinfo: ERROR: Module nvidia not found.

Why did my nvidia driver dissapear? Can you please tell me how can I restore it? Everything was fine before the update, now I can only run very simple games

I had the same issue on my F40 upgrade, which lead me down a rabbit hole of nonsense.
I had secure boot enabled on that machine as well.

I am holding back the upgrade of Fedora on my work laptop because F40 has been a mess for me on my gaming PC.

Nvidia kernel module installed on F39 that did not upgrade with the update.
There were some f39 repos left over as well.
SELinux was also messed up on my machine post upgrade.

I had to remove the kernel module manually and reinstall the drivers.

Check your repo list and kernel modules and reinstall the driver if necessary.

Are you installing via rpmfusion or nvidia package?

Exactly the same, I saw some SELinux error message, just dismissed it. The command

sudo dnf module list --enabled

returns nothing, trying to reinstall from rpm fusion:

sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda

says it is already installed and does nothing

Removed workstation

Can you reinstall the driver from RPMFusion ?

Could just try sudo akmods --force to rebuild if it’s already installed. Then wait the time it takes after that and reboot.

Check SELinux first:

To check SELinux enforcement use command getenforce, this should be set to Enforcing, if it is set to that you are ok. There was a known SELinux bug in an earlier kernel.

What kernel version are you on ?

Are you using secureboot?

You can remove nvidia driver using sudo dnf remove nvidia* --allowerasing, then reinstall.

He can not. As per his reply.

$ getenforce
Enforcing
$ uname -r
6.9.5-200.fc40.x86_64
$ lspci | grep "VGA"
01:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1070] (rev a1)

I don’t remember, will try to check that in my uefi

Will do that in a moment and come back

mokutil --sb-state

Will tell you if you have Secure Boot enabled.

If you don’t have the package then SB is not enabled in the OS.

Allright. That’s the output

$ mokutil --sb-state
SecureBoot disabled
Platform is in Setup Mode
$ sudo akmods --force
[sudo] password for paul: 
Checking kmods exist for 6.9.5-200.fc40.x86_64             [  OK  ]

Did sudo akmods --force fix your issue?

If not remove and reinstall the driver.

To remove run sudo dnf remove nvidia* --allowerasing
Then try a reinstall.

This command is not correct even for fully removing the nvidia driver.
You should instead use
sudo dnf remove \*nvidia\* --exclude nvidia-gpu-firmware --allowerasing
since the firmware package would not be reinstalled when reinstalling the akmod-nvidia package and is necessary for the gpu to be used even with the nouveau driver.

In most cases a different approach works well

  1. sudo dnf remove kmod-nvidia-\* to remove the non-functioning modules.
  2. sudo akmods --force to rebuild the modules.
  3. reboot
2 Likes

Looking good so far

Removed:
  kmod-nvidia-6.9.4-100.fc39.x86_64-3:550.90.07-1.fc39.x86_64                                                 
  kmod-nvidia-6.9.5-100.fc39.x86_64-3:550.90.07-1.fc39.x86_64                                                 
  kmod-nvidia-6.9.5-200.fc40.x86_64-3:550.90.07-1.fc40.x86_64                                                 

Complete!
$ sudo akmods --force
Checking kmods exist for 6.9.5-200.fc40.x86_64             [  OK  ]
Building and installing nvidia-kmod                        [  OK  ]
$ modinfo -F version nvidia
550.90.07

I did what Jeff V posted, restarted pc. When I try to login (plasma x11 session), it does nothing, and asks for my password again, and again. The only thing that works is plasma wayland. So far, so good. Obs studio can record video, and steam can open and run games much faster. But now this flickering happens every now and then. Even while I’m writing this post with just a browser opened
Well, everything kinda “works” in wayland, but… is there a way to restore x11 login functionality?

As I understand it they removed x11 DE in f40 kde-plasma for new installs.
It also seems that for upgrades x11 remains.

It seems it may be restored by installing the plasma-workspace-x11 package.
I don’t use kde so have not tested that.

I did install that package. I’ll try to login again with today’s update. Hope it’s fixed. Thank you very much to all people that replied to this thread

1 Like