Update again and again

I didn’t know that Silverblue bugs were in Github and not Bugzilla, but here it is:

Oh, I’ve been having this issue on my server running Fedora IoT. I thought the SD card was going bad and was going to look into it more this weekend.

It’s stuck at the image from 10 Aug:

* fedora-iot:fedora/stable/aarch64/iot
                  Version: 36.20220810.0 (2022-08-10T10:07:03Z)

When I upgrade, it looks like everything is working.

I’ll try upgrading my Silverblue systems too.

Meanwhile, updating ostree-based systems, at least from Europe, is glacial. I’m getting 23 kB/s for some odd reason. (It’s usually so much faster.) So this might impact a reply on whether IoT is having the same issues here and if the fix above for Silverblue would also work for IoT as well. (I’m assuming it’s the same bug and same fix.)


Edit: My Fedora IoT server finally upgraded with your tip about running sudo ostree admin finalize-staged

It’s now @ Version: 36.20220818.0 (2022-08-18T07:44:49Z).

Thanks! :party:

1 Like

I’m so glad to hear my solution is helpful, @passthejoe. :smiley: It is funny I’ve just switched from Silverblue to Workstation (37 pre-release). :joy:

From the bug report ([BUG] cannot update silverblue (grub2-mkconfig error) · Issue #322 · fedora-silverblue/issue-tracker · GitHub) , another fix:

rpm-ostree update
sudo grub2-mkconfig
1 Like

This works. And confirm that it is a version 36.20220810.0 where it appears. Unfortunately WWAN car do not anymore show in the mobile networks. Why is that?

Does sudo grub2-mkconfig fix the issue “permanently” or one needs to use this command during each upgrade?

When this happened, I thought it was my fault and I damaged the system due to my crazy experiments. But, if more people deal with the same issue, I guess it will be fixed soon and I should perhaps switch back to Silverblue (once a good image of 37 is available for download). :thinking:

1 Like

I’m not sure whether it was the onetime sudo grub2-mkconfig or some other package update, but my system is functioning normally as far as rpm-ostree update and rpm-ostree install goes.

I was trying to find some information on the ostree admin finalize-staged command and noticed there is no man page description or help entry for the command. Searched it on the web and came to a few GitHub issues conversations, but also found someone else had the same experience a year and a half ago:

We should fix this and create a man page and help entry for ‘finalize-staged’ so people understand what it is doing. The thread linked in systemctl cat ostree-finalize-staged.service is interesting, but I don’t see any reference to the command or systemd service itself.

1 Like

Would it be necessary to inform users via Twitter (and even cooler Mastodon) that their systems are not being updated, that there is a workaround and that it is being investigated?

2 Likes

I somehow figured out this command would possibly resolve the issue, I tried it, and it worked for me. But I definitely agree with @mpphill2 , ‘finalize-staged’ is surprisingly poorly documented.

I also agree with @Nepomuk–even if this issue is resolved, people need somehow upgrade to a new fixed deployment to get all the necessary fixes… So, they should be informed how to do it!

I’m now on Silverblue 37 pre-release (I love it! :smile:) and as for now, I have no issues with deploying and layering. All this works just fine on my system install. (Edit: I had an issue setting up the flathub remote but the workaround was simple).

This is tracked in [BUG] cannot update silverblue (grub2-mkconfig error) · Issue #322 · fedora-silverblue/issue-tracker · GitHub

What ha pend to Network manager update where it first time show WWAN card and even asking SIM card. It appears in a one what was updating again. But after fix it was not shown? How to update Network manager only?

Woaa it appears again. Just booted and it show up. I need to look if it will be stable.

Yes this feature is no stable, It do not appear today. What can cause this? Is it HW issue?

I think we should make this a separate topic, what do you think @juhafinlandvoaa ?
Let me know and I’ll move it to something like “Why is Network Manager randomly dropping my cellular modem?”

There probably won’t be a lot of experts in cellular modems here, but what I would recommend you do is reboot a few times and each time export your syslogs using GNOME Logs, then open up GNOME Terminal and redirect a dmesg output into a file (e.g. dmesg > dmesg.txt).

See if you can capture the logs in working and non-working state and try to observe the difference. If it looks like a software issue then you should contribute to the project by filing a bug at https://bugzilla.redhat.com/ !

I think Stephen has point here. There is ever growing number of WWAN in the EU. I see this card now. Yesterday i did not. I am sorry but I was so much in the work that did not respond. I have this Network Manager where I have presentation of this issue. How to transfer this info to that and modify header?

It seems to be more stable now. It appears and demanding SIM. I will look some weeks. I have now set up where 5G WWAN is outside. And will install it to PCI, M.2 card eventually.

Naa, it is a bug. It randomly shows up. Can someone help me file bugreport.

Hello @juhafinlandvoaa ,
I would ask for you to start a new topic on this matter regarding the WWAN and 5G cellular card. I believe it merits having a better title that is meaningful to the problem. Also, @mpphill2 provided the bugzilla link in their response above, you will need to use your FAS id to sign in and create an issue I would say against the kernel maybe, unless someone else has a better group in mind.

I have already topic called Network Manager. I need to copy posts there. i will make bug from it.