Unlocking default keyring with no set password?

Hello,
I’m on Fedora 36 (Nobara if that makes a difference) with KDE Plasma as my DE. Some applications cause the “An application wants to unlock the default keyring, but it is locked” popup to occur. I don’t ever remember setting this password, and I’ve tried the following:

  1. I don’t have a gnome2 folder that I could find because I use KDE as my DE, so I cannot clear that out.
  2. I’ve installed Seahorse, and there is no “Login” section to check for. Again, a gnome thing, but covering my bases.
  3. There is a section called “default keyring” which is great! I try to reset the password, but since I don’t know the old password because there isn’t one, I cannot change it.
  4. I have tried using my root password, my standard passwords from the last 10 years, and just hitting “continue” with no password - all of these are considered wrong.
  5. My digging has found out that this is due to the application wanting to store passwords in the key ring, but Fedora / KDE / Something isn’t letting it.

If I hit cancel, then it may go away, or pop up again 2-5x more times before finally going away.

I have KDEWallet disabled.

What am I missing in order to either get this to stop occurring or to stop it from popping up in general?

Thank you very much for your assistance.
-kjrhanson

EDIT: fixed typo

1 Like

The default keyring password should match your login password.
You can delete the keyring and create a new one if necessary.

1 Like