Unknown update error with libheif


Hello everyone.

I’m used to being one release behind Fedora and with the arrival of Fedora 38, for me, it’s time to upgrade to Fedora 37.

I set out to go through the same process as I do every six months, generally without problems, and this time I got the following message:

Error: Error de prueba de transacción:
  conflicto del archivo /usr/lib64/libheif/libheif-libde265.so entre instalaciones intentadas de libheif-hevc-1.15.1-2.fc37.1.x86_64 y libheif-freeworld-1.15.1-4.fc37.x86_64
  conflicto del archivo /usr/lib64/libheif/libheif-x265.so entre instalaciones intentadas de libheif-hevc-1.15.1-2.fc37.1.x86_64 y libheif-freeworld-1.15.1-4.fc37.x86_64

Error de prueba de transacción means something like Transaction test error.

So much for my update. Obviously, I could not continue. I don’t know what it is and what it means. I greatly appreciate who (whoever) can enlighten me and help me unlock the update.

The command I used for the upgrade was as follows (prior system upgrade):

dnf system-upgrade download --refresh --releasever=37 --allowerasing --best

Again, thank you all very much. :vulcan_salute:

best regards

Please read the rpmfusion faq , here : [FAQ - RPM Fusion](RPMFUSION FAQ)

install the missing package from testing repo !

sudo dnf install --enablerepo=pmfusion-free-updates-testing libheif-freeworld

should be enough , i.e. just update from testing the package you want .

Will the repo automatically disabled afterwards?

yes , is just used it that moment ,
to add permanently use:
sudo dnf config-manager --set-enabled rpmfusion-nonfree-updates-testing

And then it should be safe to upgrade to Fedora 38?

I’ve had the same problem with updating packages for “krita” and those dependecies libheif on Fedora 37, but today morning they released out “libheif-freeworld-1.15.1-5.fc37.x86_64.rpm” instead of previous “libheif-freeworld-1.15.1-4.fc37.x86_64” version and everything goes smooth with updating those packages. So probably I’ll update to Fedora 38 these days because everything seems cleared out now for me.

Should be!
But we cannot tell with certainty. Your system will tell you if there is a problem remaining.

Thank you so much, man: it worked. This solved the problem, and I was able to upgrade my system without problem.

For me, this was the solution.


Tried using the recommended upgrade method and the dnf system upgrade plugin to upgrade from Fedora 37 to Fedora 38. Both ways failed with the following message after attempting to fully up to date;

“Unable to download updates:
Error running transaction:file/user/lib64/libheif/libheif-libde265.so conflicts bwtween attempted installs of libheif-hevc-1.15.1.-2.fc 37.1X86_64 and libheif-freeworld-1.15.1-4.fc37.x86_64 file/usr/lib64/libheif/libheif-x265.so conflicts between attempted installs of libheif-hevc-1.15.1-2.fc37.1x86_64 and libheif-freeworld-1.15.1-4.fc37.x86_64.

Have not the expertise to identify the exact cause of this problem yet my guess would be a conflict between using RPM fusion and the normal dnf repository? There are no such libheif files or folder in the file/user/lib64 directory so this appears to be an initial installation of this lib file and not an upgrade of an already existing file in that directory.
Does one of these lib files need to be installed yet something is causing a conflict as to which one due to some previous installed packages with dependencies?

Tried installing the libheif-freeworld-1.15.1-4.fc37.x86_64 through a terminal and the same message of an error explaining a conflict resulted. Again tried installing the libheif-hevc package and same error message resulted.

What needs to be done for solving this problem allowing me to use the upgrade method of moving from 37 to 38 instead of deleting the partition currently running 37 and a fresh install of 38?

Try to install libheif-freeworld with this command:

sudo inf install --allowerasing libheif-freeworld
1 Like

Tried- sudo dnf install --allowerasing libheif-freeworld

The same error message results concerning conflicts between freeworld and hevc.

How about:

sudo dnf swap libheif-hevc libheif-freeworld

That should remove libheif-hevc and install libheif-freeworld in a single transaction.

1 Like

Exactly the same problem here !
Is this library required ? may we skip this upgrade and how should we do this ?

should cover it.


Had this too.

This has the answer:

you need update to libheif-freeworld-1.15.1-5 not 4 , now it should be on updates repo , so I guess your mirror is outdated