Unexpected system error Xorg-x11-drv-nouveau

Ah, my bad. I just realize there are two different manufacture: Nvidia and AMD.

Last three days I’m tries to make all hardware on my laptop working properly and it’s using old Nvidia chips. May it’s make me read all your text as Nvidia thing. LOL.


Your step to remove Nvidia driver and using only AMD driver are right. But unfortunately you got problems after remove it.

no issue, i am pretty much clueless regarding graphic driver in linux in general. The problem was there from the day i installed it and when i removed the driver everything worked but i still get those weird error notification

on startups .

if you know where to look for regarding my issue that would be cool.

I would suggest that you post the output of

inxi -Fzx

and let us see all the devices and drivers in use so we may be able to make useful suggestions. You may have to install inxi to do so.

Please post that as text and not as a screenshot.

System:    Kernel: 5.14.16-201.fc34.x86_64 x86_64 bits: 64 compiler: gcc v: 2.35.2-6.fc34 Desktop: GNOME 40.5 
           Distro: Fedora release 34 (Thirty Four) 
Machine:   Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec1xxx v: N/A serial: <filter> 
           Mobo: HP model: 87B1 v: 31.21 serial: <filter> UEFI: AMI v: F.20 date: 11/04/2020 
Battery:   ID-1: BAT0 charge: 17.7 Wh (35.2%) condition: 50.3/50.3 Wh (100.0%) volts: 10.9 min: 11.6 
           model: Hewlett-Packard Primary status: Discharging 
CPU:       Info: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2 rev: 1 cache: 
           L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71862 
           Speed: 1397 MHz min/max: 1400/3000 MHz boost: disabled Core speeds (MHz): 1: 1397 2: 1397 3: 1397 4: 1396 5: 1397 
           6: 1397 7: 1397 8: 1396 9: 1397 10: 1397 11: 1397 12: 1397 
Graphics:  Device-1: NVIDIA TU117M driver: nouveau v: kernel bus-ID: 01:00.0 
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel bus-ID: 04:00.0 
           Device-3: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo bus-ID: 3-3:3 
           Display: wayland server: X.Org compositor: gnome-shell driver: loaded: amdgpu,ati 
           unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.14.16-201.fc34.x86_64 LLVM 12.0.1) v: 4.6 Mesa 21.1.8 direct render: Yes 
Audio:     Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard 
           driver: N/A bus-ID: 04:00.5 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus-ID: 04:00.6 
           Sound Server-1: ALSA v: k5.14.16-201.fc34.x86_64 running: yes 
           Sound Server-2: PipeWire v: 0.3.39 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel 
           port: e000 bus-ID: 02:00.0 
           IF: eno1 state: down mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 bus-ID: 03:00.0 
           IF: wlo1 state: up mac: <filter> 
           IF-ID-1: virbr0 state: down mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 
           Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running rfk-block: hardware: no software: yes 
           address: see --recommends 
Drives:    Local Storage: total: 931.51 GiB used: 16.44 GiB (1.8%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB temp: 31 C 
Partition: ID-1: / size: 301.75 GiB used: 16.07 GiB (5.3%) fs: btrfs dev: /dev/sda6 
           ID-2: /boot size: 975.9 MiB used: 275.1 MiB (28.2%) fs: ext4 dev: /dev/sda5 
           ID-3: /boot/efi size: 256 MiB used: 99.5 MiB (38.9%) fs: vfat dev: /dev/sda1 
           ID-4: /home size: 301.75 GiB used: 16.07 GiB (5.3%) fs: btrfs dev: /dev/sda6 
Swap:      ID-1: swap-1 type: zram size: 7.12 GiB used: 0 KiB (0.0%) dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 32.2 C mobo: 32.0 C 
           Fan Speeds (RPM): N/A 
           GPU: device: amdgpu temp: 31.0 C device: nouveau temp: N/A 
Info:      Processes: 367 Uptime: 7m Memory: 7.12 GiB used: 2.69 GiB (37.7%) Init: systemd runlevel: 5 Compilers: gcc: 11.2.1 
           Packages: 5 note: see --pkg Shell: Bash v: 5.1.0 inxi: 3.3.06 


switcherooctl list

Try this to see both GPU in your system and Which one is default.

I also have an Optimus Graphics and that error is quite common with nouveau drivers. I think it was less frequent in X11 session even though Desktop is probably being rendered in your AMD GPU by default to save battery.

Installing Nvidia Drivers should fix that issue in Fedora 34. Enable RPM Fusion Non-free Nvidia drivers

If is says AMD GPU is Default then

sudo dnf install https://mirrors.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://mirrors.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

sudo dnf update -y

and do a reboot.

sudo dnf install akmod-nvidia

After it installs, give it 10 mins. Then reboot. Those crash popups will stop coming on every time you log in. Also don’t upgrade to Fedora 35 yet. It’s kinda bad for laptops with Dual GPUs.

As to why not disable Nvidia GPU. I tried most things. Apparently Installing Nvidia propriatery drivers is the easiest way to blacklist Nouveau and you won’t have to disable it everytime an update to kernel comes out.


I cant thank you enough, It fixed the problem no more weird crashes…

1 Like

an update:

increase in loading time after login: The main window gets completely black and takes around a min or so to load the main window. its HDD so i dont mind much im kind of used to wait for things to load but still thought to give an update here.

one question btw how will i know which graphic hardware is being used by the system?

inxi -Gzz
install inxi if needed.

I didn’t have any performance issue.

To know what’s using your Nvidia-gpu, you can try


If it’s not installed, then

sudo dnf install xorg-x11-drv-nvidia-cuda

It’ll show information like VRAM, Temp, What apps are using etc.

Xorg session is probably better if you want to game though.