Undetectable mobile broadband modem at the Network Connections window

I currently have a Huawei K3770 3G USB modem connected to my laptop, and i’ve been trying to connect to the internet through it. However after following multiple blogposts to get this kind of external modems to work, i can’t get it to show up at the Network Connections GUI window opened with the command nm-connections-editor. The dongle does show up with lsusb and mmcli output, and even the Modem Manager GUI application. However, it doesn’t show up at nmtui nor can it connect with the Modem Manager GUI app as the application just keeps loading.
Any ideas ?

You not informed which provider your modem is from. My guess is Vodafone

Indeed, it’s. I thought i should just state what i’ve tried on my fedora machine rather than the carrier, as the same dongle works on my ubuntu macine right out of the box. I didn’t even have to either install usb_modeswitch (it was firstly appended by the line segment “usb storage medium” at lsusb output).

I’ve just tried out the configuration rules at the blogpost. It firstly mentioned that “Ubuntu may describe the dongle as 14c9 instead of 1c05.”
i’m currently on fedora, and it already identifies the product ID as “14c9”. Nonetheless, i’ve added his rules but with a slight change to the modem’s product id to be of my current 14c9, yet it then resulted in the following error

> sudo usb_modeswitch -c /etc/usb_modeswitch.conf
Look for target devices ...
 No devices in target mode or class found
Look for default devices ...
 Found devices in default mode (1)
Access device 002 on bus 001
Get the current device configuration ...
Current configuration number is 1
Use interface number 0
 with class 255
Error: can't use storage command in MessageContent with interface 0; interface class is 255, expected 8. Abort

I’ve also proceeded with using the tool Sakis3G, which kept popping hovering mandatory prompts like a username and a password (typically not required), then upon completion it stated that it connected, but in practice it didn’t.

Check if your user, you are using with the modem, is in the dialout group.
You can test this in the terminal typing groups, if dialup not appears you can try to put your user into it.

Thanks! it did work after appending the user to the dialout group. However i wold really appreciate if there’s an explanation behind this. Also, the nm-network-manager still doesn’t show the device at the set up a Mobile Broadband connection wizard .

I’m sure you have but since making the changes have you rebooted.

I did, but still the usb modem not showing up at the set up a Mobile Broadband connection wizard .

The aforementioned solution seems now to be rather quirky, as it sometimes connect, and other don’t without any single indication. If there’s way t meditate a problem that’s hindering the device from being displayed at both the GUI wizard, then that would probably do it.
The quirky behavior goes like this: Firstly you’ll have to enable both the wifi and modem by $ nmcli radio wifi on and $ mmcli -m {modemIndex} --enable then connect (no actual cellular connection, just the modem illuminating). Later on if you let’s say issued $ sudo ./sakis3g disconnect then it’ll disconnect i.e. de-illuminate , then if you were to connect back again, you’ll have to either reconnect the usb modem , or invoke $ sudo udevadm control --reload-rules. It’s a real hassle.

If the connection is invisible it is not apearing … you have to add it as:

Connect to a hidden WI-Fi network and put the sid manually.

I’ve added a comment prior to that but it got removed by spam filters for some reason.
Anyways, that’s what i’m actually facing right now

As you can see, the select device dropdown menu is inactive , despite the deving being loaded

and here’s the output of several commands

$ nmcli device show
GENERAL.DEVICE:                         wlp2s0
GENERAL.TYPE:                           wifi
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.CONNECTION:                     netData
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/4
IP4.ROUTE[1]:                           dst =, nh =, mt = 600
IP4.ROUTE[2]:                           dst =, nh =, mt = 600
IP4.DOMAIN[1]:                          home
IP6.ADDRESS[1]:                         fd$$$$$$$$$$$$$$
IP6.ADDRESS[2]:                         fe$$$$$$$$$$$$$$
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           $$$$$$$$$$$$$$
IP6.ROUTE[2]:                           dst = fd$$$$$$$$$$$$$$::/64, nh = ::, mt = 600
IP6.DNS[1]:                             fe80::1

GENERAL.DEVICE:                         eno1
GENERAL.TYPE:                           ethernet
GENERAL.HWADDR:                         E8$$$$$$$$$$$$$$
GENERAL.MTU:                            1500
GENERAL.STATE:                          20 (unavailable)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
IP4.GATEWAY:                            --
IP6.GATEWAY:                            --

GENERAL.DEVICE:                         lo
GENERAL.TYPE:                           loopback
GENERAL.HWADDR:                         00:00:00:00:00:00
GENERAL.MTU:                            65536

$ mmcli -L
    /org/freedesktop/ModemManager1/Modem/2 [huawei] K3770

$ mmcli -m 2 
  General  |              path: /org/freedesktop/ModemManager1/Modem/2
           |         device id: 270e93ddd98805830a686aebd39ac09e94b43a9e
  Hardware |      manufacturer: huawei
           |             model: K3770
           | firmware revision:
           |         supported: gsm-umts
           |           current: gsm-umts
           |      equipment id: 356742043468260
  System   |            device: /sys/devices/pci0000:00/0000:00:08.1/0000:03:00.3/usb1/1-1
           |           drivers: option
           |            plugin: huawei
           |      primary port: ttyUSB3
           |             ports: ttyUSB0 (at), ttyUSB3 (at)
  Status   |    unlock retries: sim-pin (3), sim-puk (10), sim-pin2 (3), sim-puk2 (10)
           |             state: registered
           |       power state: on
           |       access tech: umts
           |    signal quality: 64% (recent)
  Modes    |         supported: allowed: 2g, 3g; preferred: none
           |                    allowed: 2g, 3g; preferred: 2g
           |                    allowed: 2g, 3g; preferred: 3g
           |                    allowed: 2g; preferred: none
           |                    allowed: 3g; preferred: none
           |           current: allowed: 2g, 3g; preferred: 3g
  IP       |         supported: ipv4
  3GPP     |              imei: 3$$$$$$$$$$$$$$
           |       operator id: 60202
           |     operator name: Vodafone
           |      registration: home
  SIM      |  primary sim path: /org/freedesktop/ModemManager1/SIM/2

$ systemctl status ModemManager
● ModemManager.service - Modem Manager
     Loaded: loaded (/usr/lib/systemd/system/ModemManager.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2022-03-13 15:59:39 EET; 2h 0min ago
   Main PID: 853 (ModemManager)
      Tasks: 3 (limit: 3932)
     Memory: 8.6M
        CPU: 5.974s
     CGroup: /system.slice/ModemManager.service
             └─853 /usr/sbin/ModemManager

Mar 13 17:47:23 fedora ModemManager[853]: <info>  [sleep-monitor] system is resuming
Mar 13 17:47:26 fedora ModemManager[853]: <info>  [base-manager] couldn't check support for device '/sys/devices/pci0000:00/0000:00:01.6/0000:01:00.0>
Mar 13 17:47:26 fedora ModemManager[853]: <info>  [base-manager] couldn't check support for device '/sys/devices/pci0000:00/0000:00:01.7/0000:02:00.0>
Mar 13 17:48:00 fedora ModemManager[853]: <info>  [device /sys/devices/pci0000:00/0000:00:08.1/0000:03:00.3/usb1/1-1] creating modem with plugin 'hua>
Mar 13 17:48:00 fedora ModemManager[853]: <warn>  [plugin/huawei] could not grab port ttyUSB2: Cannot add port 'tty/ttyUSB2', unhandled port type
Mar 13 17:48:00 fedora ModemManager[853]: <info>  [base-manager] modem for device '/sys/devices/pci0000:00/0000:00:08.1/0000:03:00.3/usb1/1-1' succes>
Mar 13 17:48:06 fedora ModemManager[853]: <warn>  [modem2/sim2] couldn't load list of emergency numbers: Failed to parse CRSM query result '+CRSM: 10>
Mar 13 17:48:06 fedora ModemManager[853]: <warn>  [modem2] couldn't load list of own numbers: SIM busy
Mar 13 17:48:07 fedora ModemManager[853]: <warn>  [modem2] couldn't load UE mode of operation for EPS: Unknown error
Mar 13 17:48:07 fedora ModemManager[853]: <info>  [modem2] state changed (unknown -> disabled)