Unbearable stutters, nvidia gtx 1080 rpm fusion 545 package

Hello, I can’t get my nvidia GPU (gtx 1080) to work with any proprietary nvidia drivers. I checked both versions that are available through rpm fusion repo (545 and 535) both end up giving pretty much an unusable user experience (weird graphic glitches like disappearing letters while typing, artifacts on screen, constant flickers). I also tried manually installing 525 without using rpm, but the experience was while seemingly better, still very far from stable and ‘usable’. Unfortunately, as of now only the nouveau works as expected without giving me any visual glitches, it works and looks completely normal. I saw in the earlier thread that someone had fixed it by changing refresh rate to 60hz → it did not do anything for me. I’m using kernel 6.7.4-200.fc39.x86_64.

I’m not sure what to do now, I’ve never experienced such problems with nvidia proprietary drivers

Added x11

Welcome to Fedora @patbsh

As you can see on kernel.org , Fedora is following the Stable kernel from it. This means when a new Kernel is introduced some adaptions have to be made. And we, the community have to give feedback and report problems to fix this bad behavior.

Unfortunately Nvidia Drivers also have to be adapted. We are now in this stage. So if you need a working system other than with Nouveau drivers, you have the possibility to relay on long-term Kernels. On this the NVIDIA Drivers should work.

1 Like

Thank you for the links and explanation.

EDIT:

I tried the long-term kernel (6.1) without any luck unfortunately. The stutter issues still seem to persist. System starts and looks okay initially, but the longer it is running the more issues occur. I made sure that Nouveau drivers aren’t working and it looks okay as

lsmod |grep nouveau

does not return anything.
I also tried reinstalling nvidia drivers. As of now Nouveau looks like the only unbroken option unfortunately in my system.

That shows the nouveau drivers are not loaded.
Please rerun that as lsmod | grep -E 'nouveau|nvidia' and also show us the return from dnf list installed \*nvidia\* as well as inxi -Fzxx.

I am not sure where you installed the nvidia drivers from but I do not recall that the 525 drivers are available from rpmfusion so if you installed from some source other than rpmfusion there could be lingering files that conflict.

Note that by default the nvidia modules are unsigned so they will only load if secure boot is disabled.

lsmod | grep -E 'nouveau|nvidia'

nvidia_drm            102400  33
nvidia_modeset       1556480  6 nvidia_drm
nvidia_uvm           3301376  0
nvidia              61546496  189 nvidia_uvm,nvidia_modeset
video                  69632  2 asus_wmi,nvidia_modeset

dnf list installed \*nvidia\*

Installed Packages
akmod-nvidia.x86_64                               3:545.29.06-3.fc39         @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.1.77-200.fc39.x86_64.x86_64         3:545.29.06-3.fc39         @@commandline                   
nvidia-gpu-firmware.noarch                        20240115-2.fc39            @updates                        
nvidia-modprobe.x86_64                            3:545.29.06-1.fc39         @rpmfusion-nonfree-nvidia-driver
nvidia-persistenced.x86_64                        3:545.29.06-1.fc39         @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                            3:545.29.06-1.fc39         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                        3:545.29.06-2.fc39         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64                   3:545.29.06-2.fc39         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.i686                3:545.29.06-2.fc39         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64              3:545.29.06-2.fc39         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64                3:545.29.06-2.fc39         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.i686                     3:545.29.06-2.fc39         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64                   3:545.29.06-2.fc39         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64                  3:545.29.06-2.fc39         @rpmfusion-nonfree-nvidia-driver

inxi -Fzxx

System:
  Kernel: 6.1.77-200.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.40-14.fc39
  Desktop: GNOME v: 45.3 tk: GTK v: 3.24.41 wm: gnome-shell dm: GDM
    Distro: Fedora Linux 39 (Workstation Edition)
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: PRIME Z690-P D4 v: Rev 1.xx
    serial: <superuser required> part-nu: SKU UEFI: American Megatrends v: 1620
    date: 08/13/2022
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) status: discharging
  Device-2: hidpp_battery_1 model: Logitech MX Keys Wireless Keyboard
    serial: <filter> charge: 100% (should be ignored) status: discharging
CPU:
  Info: 16-core (8-mt/8-st) model: 12th Gen Intel Core i9-12900K bits: 64
    type: MST AMCP arch: Alder Lake rev: 2 cache: L1: 1.4 MiB L2: 14 MiB
    L3: 30 MiB
  Speed (MHz): avg: 800 min/max: 800/5100:5200:3900 cores: 1: 800 2: 800
    3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800
    13: 800 14: 800 15: 800 16: 800 17: 800 18: 800 19: 800 20: 800 21: 800
    22: 800 23: 800 24: 800 bogomips: 152985
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Gigabyte driver: nvidia
    v: 545.29.06 arch: Pascal ports: active: none off: DP-3 empty: DP-1, DP-2,
    HDMI-A-1, HDMI-A-2, HDMI-A-3 bus-ID: 0000:01:00.0 chip-ID: 10de:1b80
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 23.2.4
    compositor: gnome-shell driver: gpu: nvidia,nvidia-nvswitch display-ID: 0
  Monitor-1: DP-3 model: Samsung C49HG9x res: 3840x1080 dpi: 82
    diag: 1242mm (48.9")
  API: OpenGL v: 4.6.0 vendor: nvidia v: 545.29.06 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2
    display-ID: :0.0
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: Intel Alder Lake-S HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 0000:00:1f.3 chip-ID: 8086:7ad0
  Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:10f0
  Device-3: GYROCOM C&C Fiio E10 driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 bus-ID: 1-9.3:8
    chip-ID: 1852:7022
  API: ALSA v: k6.1.77-200.fc39.x86_64 status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
    port: 3000 bus-ID: 0000:04:00.0 chip-ID: 10ec:8125
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: ASUSTek Broadcom BCM20702A0 Bluetooth driver: btusb v: 0.8
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 bus-ID: 1-8:3 chip-ID: 0b05:17cb
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
    lmp-v: 6
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 bus-ID: 0000:00:0e.0 chip-ID: 8086:467f
Drives:
  Local Storage: total: 2.19 TiB used: 27.56 GiB (1.2%)
  ID-1: /dev/nvme0n1 vendor: GOODRAM model: IR-SSDPR-P34B-01T-80
    size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 27.9 C
  ID-2: /dev/nvme1n1 vendor: GOODRAM model: N/A size: 111.79 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 58.9 C
  ID-3: /dev/sda vendor: SanDisk model: SSDPR-CX400-01T-G2 size: 953.87 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-4: /dev/sdb vendor: GOODRAM model: N/A size: 223.57 GiB speed: 6.0 Gb/s
    serial: <filter>
Partition:
  ID-1: / size: 952.27 GiB used: 27.01 GiB (2.8%) fs: btrfs dev: /dev/dm-0
    mapped: luks-a2d2329b-5938-407e-919e-20d9c5e77628
  ID-2: /boot size: 973.4 MiB used: 546.4 MiB (56.1%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 19 MiB (3.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 952.27 GiB used: 27.01 GiB (2.8%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-a2d2329b-5938-407e-919e-20d9c5e77628
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 24.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 24 GiB note: est. available: 23.2 GiB used: 2.76 GiB (11.9%)
  Processes: 507 Power: uptime: 11m wakeups: 0 Init: systemd v: 254
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 15 Compilers: gcc: 13.2.1 Shell: Zsh v: 5.9
    running-in: kitty inxi: 3.3.32

They are not, I manually installed them (got them from the nvidia’s website) but they did not work either so I uninstalled them and rolled back to rpm fusion.

Also, the problem started before trying them, it occurs on both versions available through rpm fusion, and they are also what I tried initially.

Yes, I have secure boot disabled, but also had them signed before (following the rpm fusion article).

Do you have the issue’s with wayland as well as using xorg.

Yes, switching to wayland on proprietary driver did not help

Manual Nvidia Driver Install issues on Fedora :

All the issues I’ve seen recently are from people doing the “If-Not-True-Then-False” or Manual Download from Nvidia site way, of installing the Nvidia drivers. If possible, remove them and setup the RPMFusion or Negativo17 repo and install the drivers that way.

The manual install of the Nvidia driver breaks after a kernel update, the instructions from that one site or YouTube video doesn’t cover this and most people end up with broken displays.


1 Like

I had them removed already, but I followed your advice and unchecked the RPM fusion from the gnome software app, I removed the drivers using
(sudo dnf autoremove) and then reinstalled the drivers using

sudo dnf install akmod-nvidia && sudo dnf install xorg-x11-drv-nvidia-cuda

after reboot and selecting X11 gnome from the login screen it seems to be working good! Wayland is still broken from what I’ve seen but the x11 works perfectly, and this is on the 6.7.4 kernel!

Thank you, I’ll work on it for a while to make sure, but this probably really is the solution.

Please tell me more. . .

What software are you using ?

It is much better than before reinstalling the right way with rpm-fusion, most problems are gone.

But I still have issues with chrome, it does seem choppy and will stutter randomly. Typing in VS Code was problematic (the disappearing letters) before and is now gone. These are the most two important apps I need.

I just tried running a game from steam to see if there are any visible differences and yes, on x11 it runs perfectly smooth, on wayland there is a short stutter (with a black blink) with every click. The game I tried is crusader kings 2.

I would do a dnf -y distro-sync when you get a chance. Makes sure you have everything going the right way now that the driver is installed and ready. If you have any other issues, please do post. Also if you could mark the answer above as a Solution. You can open a new thread if other problems persist.

1 Like

dnf distro-sync is better so people see the errors if there are some. And thanks for mentioning distro-sync :slight_smile:

Nvidia + Wayland on Fedora 39 (for me, but others report similar issues) is unstable in e.g. Steam/Electron based apps (VSCode, Chrome), but not e.g. firefox. Symptoms being tearing, low latency (poor refresh), sometimes artifacts. Switching to X, then using nvidia-settings to switch powermizer to maximum resolved it for me (unable to update kernel/driver for now).
Driver 545.29.06 (rpmfusion), kernel 6.6.11-200.fc39.x86_64

Steam does not use Wayland. It is running under Xwayland.

There are multiple issues reported with XWayland from users using XWayland in Wayland session for compatibility with certain applications, notably Electron-based app.
There is one on XOrg’s XServer (Issue #1317) and there is another on GNOME’s Mutter (Issue #3241).

This thread currently has a solution, If anyone else is having issues, Please open a thread so we can help you troubleshoot.

This thread was directed at a Installation/Reinstall of an Nvidia driver.

If anyone is having issues, Open a new thread.

Note that the 6.6.11 kernel is rather old and the 6.7.4 kernel seems to work well with steam (especially with xorg DE).

The current kernel is 6.7.4 and the current nvidia driver is 545.29.03-3

# dnf list akmod-nvidia
Installed Packages
akmod-nvidia.x86_64                               3:545.29.06-3.fc39                                @rpmfusion-nonfree-nvidia-driver