Unable to use Wayland after removing NVIDIA drivers


I have this problem after trying(unsuccessfully) installing NVIDIA drivers for my GTX GPU I had to remove because it was only defaulting for nouveau drivers.

Now I can’t use Wayland on my Silverblue. It only defaults to X11. I can’t find the other solution that some folks did, copying from your /etc or something right now but that did not work for me.


We need a little more information. How did you install the drivers and how did you remove them?

To me that seems to indicate you have secure boot enabled, which prevents the kernel loading the nvidia drivers.

You could reinstall the nvidia drivers and disable secure boot then things should work.

Please post the output of inxi -Fzxx in the </> Preformatted text tags available on the menu bar.

Please stop bumping your own thread. We are all volunteers and bumping your own thread is equivalent to demanding a response. We are not a paid help desk.

We need the info asked for inxi -Fzxx

No, bumping just means putting your topic on display.

But I knew Linux forums were the definition of uselessness.