Unable to upgrade to F32 from F31 fwupd.service error

I am trying to upgrade from F31 to F32 I have run it with dnf system-upgrade download --refresh --releasever=32 --allowerasing then when all packages are down loaded I get the following error: Transaction test error:
file /usr/lib/systemd/system/fwupd.service conflicts between attempted installs of fwupd-1.4.1-1.fc32.i686 and fwupd-1.4.1-1.fc32.x86_64.

any suggestions on what I need to do to get around this?

Hi @bmccall3, welcome to the Fedora community!
If you’ve not had a chance yet, please look at the #start-here category. It has some very useful information on using the forum and tips on Fedora usage.

You have both the i686 (32 bits) and x86_64 (64bits) version of the package installed. That causes confusion.

It is recommended you uninstall the .i686 package:

sudo dnf remove fwupd-1.4.1-1.fc32.i686
1 Like

I don’t have fwupd-1.4.1-1.fc32.i686 installed the upgrade is trying to install it. Also It is not installed at all the only package installed is fwupd-1.3.9-2.fc31.x86_64.

It wouldn’t hurt to remove fwupd before running the update, would it?

sudo dnf remove fwupd

Then run the update. After the update if you need fwupd, install it again with:

sudo dnf clean metadata
sudo dnf install fwupd

I ran that command and still renders the same result it still displays
Error: Transaction test error:
file /usr/lib/systemd/system/fwupd.service conflicts between attempted installs of fwupd-1.4.1-1.fc32.i686 and fwupd-1.4.1-1.fc32.x86_64
at the end of the up grade.
I have removed the packages rebooted and it is still trying to install the packages

Downloading Packages:
(1/2693): ostree-2020.3-2.fc32.x86_64.rpm 497 kB/s | 227 kB 00:00
(2/2693): ostree-2020.3-2.fc32.i686.rpm 463 kB/s | 232 kB 00:00
(3/2693): ostree-libs-2020.3-2.fc32.i686.rpm 2.6 MB/s | 430 kB 00:00
(4/2693): ostree-libs-2020.3-2.fc32.x86_64.rpm 3.2 MB/s | 398 kB 00:00
(5/2693): python2-setuptools-41.2.0-2.fc32.noarch.rpm 5.4 MB/s | 574 kB 00:00
(6/2693): f32-backgrounds-kde-32.2.0-1.fc32.noarch.rpm 113 kB/s | 13 kB 00:00
(7/2693): libappindicator-gtk3-12.10.0-27.fc32.x86_64.rpm 45 kB/s | 42 kB 00:00
(8/2693): fwupd-1.4.1-1.fc32.i686.rpm 1.1 MB/s | 1.1 MB 00:01

as you can see it is selecting the package on it’s own.

I have ran dnf system-upgrade clean and started all over and still the same results.

Also I am running Fedora 31 KDE if that matters.

Hello I ran

dnf system-upgrade download --refresh --releasever=32 --allowerasing --exclude fwupd

and it worked thanks for all of the help.

marking this thread as fixed.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.