Unable to update from Silverblue 31 to Silverblue 32

Hello. I have been running Fedora Silverblue 31 for a while, and recently saw that Fedora Silverblue 32 is available. I tried to update via GNOME Software, but the update failed. I’ve tried a few times since then, thinking that the issue might get fixed, but it still won’t work.

When I try to update via GNOME Software, it downloads, and then eventually displays an error saying “Unable to upgrade to Fedora 32: Could not depsolve transaction, 2 problems detected:”. It doesn’t say what the two problems are.

When I look in GNOME Logs, I can see the following more detailed message:

Txn Rebase on /org/projectatomic/rpmostree1/fedora failed: Could not depsolve transaction; 2 problems detected:
Problem 1: conflicting requests

  • nothing provides system-release(31) needed by rpmfusion-free-release-31-1.noarch
    Problem 2: conflicting requests
  • nothing provides system-release(31) needed by rpmfusion-nonfree-release-31-1.noarch

So it seems like this is an issue related to RPM Fusion. I thought this is quite a common thing to use, and part of the appeal of Fedora Silverblue is that the common OS image makes it easy to test for issues. It’s disappointing that this update isn’t working smoothly.

Could anyone please tell me what I need to do to update successfully? Thanks.

Yeah, this is quite a common annoyance when rebasing.

You need to rpm-ostree uninstall rpm-fusion and packages installed through it (very likely compat-ffmpeg28 is one of them).

Then proceed with the rebase. After completing the rebase, reboot and reinstall rpm-fusion repo and associated packages you need.


No you don’t!

For example this will rebase you to F34 beta without having to uninstall any rpmfusion packages

rpm-ostree rebase fedora:fedora/34/x86_64/silverblue --uninstall rpmfusion-free-release-33-1.noarch --install https://mirrors.rpmfusion.org/free/fedora/rpmfusion-free-release-branched.noarch.rpm --uninstall rpmfusion-nonfree-release-33-1.noarch --install https://mirrors.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-branched.noarch.rpm