Unable to run MPD after installing through livna

when i install then run mpd on fedora 35 i get the error (mpd: symbol lookup error: mpd: undefined symbol: _ZN3fmt2v86detail18throw_format_errorEPKc)
i have no idea how to fix

Just to be sure, did you install mpd from RPM Fusion? livna is ancient and got merged to rpm fusion about 14 years ago. So in case you did get your rpm package from a site claiming to be livna it might either be outdated or a scam.

If you did install mpd from RPM Fusion, then it should work fine, but since I do not use mpd myself I cannot help you further.

1 Like

i tried through rpm fusion it gives the same error

1 Like

Fedora 35 x86_64
The missing symbol _ZN3fmt2v86detail18throw_format_errorEPKc for mpd-0.23.6 https://koji.rpmfusion.org/kojifiles/packages/mpd/0.23.6/1.fc35/x86_64/mpd-0.23.6-1.fc35.x86_64.rpm
is provided by fmt-8.1.1 from 35 updates repo

Mpd-0.23.6 works on my system so I verified the library providing the symbol.

nm -D /usr/lib64/libfmt.so.8.1.1 | grep _ZN3fmt2v86detail18throw_format_errorEPKc
0000000000004870 T _ZN3fmt2v86detail18throw_format_errorEPKc

dnf repoquery -f /usr/lib64/libfmt.so.8.1.1 
Last metadata expiration check: 3:11:06 ago on Tue 26 Apr 2022 03:51:25 PM EDT.