Unable to run flatpaks

The summary of the problem is : I am able to install but not to run or sometimes not even to install flatpacks. First I though it was becaseu of the SCAP Workbench hardening I did. But when I installed on a total of three virtual machines and had ran multiple different test but I wasn’t able to run flatpaks even with-out the security hardening implemented.

An example of the error while I installed Bitwarden and then tried opening the software (note it’s the same with evey Flatpack) :

Have you tried run from a commend line

flatpak run com.bitwarden.desktop

Runs or not if not what are the errors
And try to repair flatpak

$ sudo flatpak repair --system --reinstall-all

See for yourself:

$ flatpak run com.bitwarden.desktop
bwrap: Creating new namespace failed: No space left on device
error: ldconfig failed, exit status 256
$ sudo flatpak repair --system --reinstall-all
[sudo] password for d4u: 
[2/31] Verifying flathub:runtime/org.freedesktop.Platform.GL.default/x86_64/21.0[7/31] Verifying flathub:runtime/org.kde.WaylandDecoration.QGnomePlatform-decora[14/31] Verifying flathub:runtime/org.kde.PlatformTheme.QGnomePlatform/x86_64/5.[22/31] Verifying flathub:runtime/org.freedesktop.Platform.VAAPI.Intel/x86_64/21[31/31] Verifying flathub:runtime/org.freedesktop.Platform/x86_64/21.08…
Checking remotes...
Pruning objects
Erasing .removed
Reinstalling refs
Installing app/com.bitwarden.desktop/x86_64/stable
Installing app/network.loki.Session/x86_64/stable
Installing runtime/org.freedesktop.Platform.GL.default/x86_64/21.08
Installing runtime/org.freedesktop.Platform.Locale/x86_64/21.08
Installing runtime/org.freedesktop.Platform.VAAPI.Intel/x86_64/21.08
Installing runtime/org.freedesktop.Platform.openh264/x86_64/2.0
Installing runtime/org.freedesktop.Platform/x86_64/21.08
Installing runtime/org.gnome.Platform.Locale/x86_64/41
Installing runtime/org.gnome.Platform/x86_64/41
Installing runtime/org.kde.KStyle.Adwaita/x86_64/5.15-21.08
Installing runtime/org.kde.Platform.Locale/x86_64/5.15-21.08
Installing runtime/org.kde.Platform/x86_64/5.15-21.08
Installing runtime/org.kde.PlatformTheme.QGnomePlatform/x86_64/5.15-21.08
Installing runtime/org.kde.PlatformTheme.QtSNI/x86_64/5.15-21.08
Installing runtime/org.kde.WaylandDecoration.QGnomePlatform-decoration/x86_64/5.15-21.08
Reinstalling appstream

Can we see the output of:

find /proc/sys/user -type f -print -exec cat {} \;   

Here you go :

$ find /proc/sys/user -type f -print -exec cat {} \;

That seems problematic. Is that the default or did you do something to remove or limit user namespaces?

1 Like

No changes where made on my part regarding it.

What about df -h
Maybe it is not related, but no space left on device… which device?

That is about the user namespaces referenced above.

It seems to be set to 0 so there are none available when it tries to create them.

None of my Fedora 34 machines have that set to 0.

If that isn’t the default, have you run any kind of security tool that may have made changes @fedoranewbie


Are you running this in a container?

can you check:
sudo sysctl -a | grep max_user_namespaces

and then
cd /etc/sysctl.d/
grep max_user_namespaces *

1 Like

I find something with similar issue

They have resolve that issue at least
But i could not understand it’s terms

$ df -h
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        3.8G     0  3.8G   0% /dev
tmpfs           3.9G  120M  3.8G   4% /dev/shm
tmpfs           1.6G  2.1M  1.6G   1% /run
/dev/dm-0       167G  8.3G  158G   5% /
tmpfs           3.9G  3.8M  3.9G   1% /tmp
/dev/dm-0       167G  8.3G  158G   5% /home
/dev/loop0       56M   56M     0 100% /var/lib/snapd/snap/core18/2253
/dev/loop1      128K  128K     0 100% /var/lib/snapd/snap/bare/5
/dev/loop2       62M   62M     0 100% /var/lib/snapd/snap/core20/1242
/dev/loop5      219M  219M     0 100% /var/lib/snapd/snap/gnome-3-34-1804/77
/dev/loop3       93M   93M     0 100% /var/lib/snapd/snap/session-desktop/192
/dev/loop7       43M   43M     0 100% /var/lib/snapd/snap/snapd/14066
/dev/loop6      226M  226M     0 100% /var/lib/snapd/snap/riseup-vpn/172
/dev/loop4       66M   66M     0 100% /var/lib/snapd/snap/gtk-common-themes/1519
/dev/sda1       976M  317M  593M  35% /boot
tmpfs           784M  816K  783M   1% /run/user/1000

Well then my money is on SCAP Workbench .

$ sudo sysctl -a | grep max_user_namespaces

[sudo] password for d4u: 
user.max_user_namespaces = 0
$ cd /etc/sysctl.d/
grep max_user_namespaces *
# Per CCE: Set user.max_user_namespaces = 0 in /etc/sysctl.conf
user.max_user_namespaces = 0

There it is. Remove or comment out that line and reboot.

1 Like

My name says it all fedoranewbie so , I do need instructions.

One of the files in /etc/sysctl.conf contains that line.

You can find out which with cd /etc/sysctl.d/ ; grep -H max_user_namespaces *

Then edit that file and find the line what looks like user.max_user_namespaces = 0 and either comment it out by adding # in front of it or delete it from the file.

1 Like

Done everything but I am still unable to run Flathub.

Did you reboot? If so, try running it from the terminal again.

flatpak run com.bitwarden.desktop

I did and than I ran the commands :

$ flatpak run com.bitwarden.desktop
bwrap: Creating new namespace failed: No space left on device
error: ldconfig failed, exit status 256
[d4u@meow ~]$