Unable to play H.265 Video


I’ve been trying to get H.265 video working on any linux distro and am unable to. I’ve tried multiple codecs without luck. In Ubuntu after installing codecs it has insane grey artifacts in VLC. In Fedora I get the error below, like theres no codec installed. Once I open the codec “GStreamer Multimedia Codecs - Extra” It says already installed. It works fine on the same Intel J4105 processor in Windows 10. Is H.265 video supported in Fedora or is it some intel/linux compatibility issue.


1 Like

You need to add the rpmfusion repos. The quickest way to get multimedia working would be this one line:

sudo dnf install https://mirrors.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://mirrors.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm && sudo dnf groupupdate multimedia --setop="install_weak_deps=False" --exclude=PackageKit-gstreamer-plugin && sudo dnf groupupdate sound-and-video

It looks like a lot, but it is essentially just adding extra repositories, then downloading the most commonly used multimedia codecs etc.

Another good thing to do is to add Flathub for even more software.


Thanks a lot man! That fixed it and now it’s working 100%. I spent so long looking for a solution and finally got it!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.