Unable to permanently change IO scheduler through kernel options in grub config

First, I have switched the BLS off as I am confused by what it is, and how it works. And I am sad from the way the change has been communicated.

I am trying to change the default mq-deadline scheduler to BFQ as it seems to work better on my HDD. But it doesn’t work as expected (afaik).

I added the elevator=bfq at the end of GRUB_CMDLINE_LINUX, and run grub2-mkconfig. The option is visible in /proc/cmdline but the scheduler is remains mq-deadline.

Arch Wiki (Imporving performance: input / output schedulers)

Isn’t bfq a default one (at least for HDD)?

cat /sys/block/*/queue/scheduler
mq-deadline kyber [bfq] none
mq-deadline kyber [bfq] none
1 Like

You’ll want to use a udev rule for that, below is provided as an example.


ACTION=="add|change", KERNEL=="nvme[0-9]*", ATTR{queue/scheduler}="none"
# set scheduler for SSD and eMMC
ACTION=="add|change", KERNEL=="sd[a-z]|mmcblk[0-9]*", ATTR{queue/rotational}=="0", ATTR{queue/scheduler}="mq-deadline"
# set scheduler for rotating disks
ACTION=="add|change", KERNEL=="sd[a-z]", ATTR{queue/rotational}=="1", ATTR{queue/scheduler}="bfq"

Ref: https://wiki.archlinux.org/index.php/Improving_performance#Changing_I/O_scheduler


Please, consider to move the

outside of ``` ```, to it not be considered a part of the config by an newbie.

1 Like

nope, at least not on my computer. I’m upgrading since f21 and no changes to schedulers made by myself.
I was wondering if it shouldn’t be default on HDD as the performance/responsiveness difference is apparent.

Thank you! Worked like a charm. I haven’t gotten to that page properly yet.

Also, consider completing the comment # set scheduler for NVMe for the first option. It got me confused for a sec before I saw the wiki page.

here is the reference to know what is it? and how is works?



1 Like

Yes, exactly! And I’ve read more, so I know that I am not the only one with this opinion.

Note: please be very careful when using Arch wiki pages as references. They may not always apply to Fedora systems.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.