Unable to mount samba share on Fedora 31 which Fedora 30/Windows has no problem with

I am trying to mount a samba share in Fedora 31.

I have done the following:

firewall-cmd --permanent --add-service=samba
firewall-cmd --reload

If I try and load the share through Dolphin, by putting this in the address bar:


Internal Error
Please send a full bug report at https://bugs.kde.org
Unknown error condition in stat: Software caused connection abort

If I try and mount it with:

mount -t cifs -o username=*****,password=****** // /mnt/

I get :

mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

Dmesg shows:

CIFS VFS: cifs_mount failed w/return code = -2

If I try smbclient:

smbclient // -U admin

this gives:

protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED

I have tried to see if I could see the mount from a machine running Windows 7, and the mount is discovered through the file browser, and I can access it, so I know there isn’t a problem on the smb side.

On Fedora 30, I was able to access the share using the ‘Add Network Folder’ option in Dolphin.

to me parts of info are left:

  • on what OS is the samba server running ?
  • if Fedora: what are the selinux labels of the share (see ls -lZ) ?
  • the share name is “admin/sharename” ?

in general:
I just setup a F31(Gnome) in an virtual machine (with a bridged IP adresse) to test smb problems in another thread in this forum.
My other box (the smb client) is also an F31(Gnome).
I test all your above commands except your part with dolphin, but did it with nautilus.

I have neither trouble to mount the shares nor do I see your above errors

So I wonder what is so different to your and my box (except KDE) regarding samba ?

on what OS is the samba server running ?
It’s a Huawei F2000 modem with a USB stick plugged into it. It has a Samba sharing service which I have enabled. It then shares out the contents of the USB stick.

the share name is “admin/sharename
I just used the same path that worked with windows.

This is what I did on Fedora 30 and it worked ok:

This solution worked for me:


Update /etc/samba/smb.conf with:

client min protocol = NT1


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.