Unable to Launch .desktop File in Fedora 38

Hello everyone,

I’m currently experiencing an issue with launching a .desktop file in Fedora 38. The .desktop file is intended to open a standalone WhatsApp application that I’ve created using Nativefier.

I created a WhatsApp.desktop file with the following content:

[Desktop Entry]

I’ve placed this file in the ~/.local/share/applications directory and made it executable with chmod +x. However, when I double-click the WhatsApp.desktop file, it opens in a text editor instead of launching the WhatsApp application. If I right-click the file and select “Open With Other Application”, there’s no option to open the file with the system application launcher.

I tried setting Nautilus as the default handler for .desktop files with gio mime application/x-desktop org.gnome.Nautilus.desktop, but this didn’t resolve the issue.

I’m not sure what else to try at this point. Any help would be greatly appreciated! Thanks! :pray:

Well, that is expected behavior, because the desktop file is just a text file. You can try to find launcher in “Activities” overview [super + a]. If it’s not there, Instal “alacarte” and save yourself from trouble of manually creating “desktop files” in future. :wink: HTH

Wow, thanks for the quick response. This is the workaround I was looking for! The “alacarte” approach worked perfectly. You’re a lifesaver! :saluting_face: