Unable to install Fedora 32 in VirtualBox in EFI mode

Fedora 32 doesn’t seem to start the kernel when booted in virtualbox (6.1.6) in EFI mode, regardless of what I try. Both the beta and the final release seem to have this problem. Both will boot in BIOS mode.

If it’s any help, my CPU is a Ryzen 3600, and the VM has 2 GB of RAM allocated to it.

Has anyone else encountered this problem?

1 Like

Welcome @hamishtmb to Ask.Fedora!

I just tested following setup and it works fine:

Host: Win10 (Intel i5)
Virtualbox: 6.1.6
Resources for VM: 1 CPU, 3 GB RAM
Guest: Fedora 32, Workstation
EFI: enabled
VM Settings: VT-x/AMD-V, Nested Paging, KVM paravirtualization (defaults)

1 Like

Neither the beta nor the final release will boot in EFI mode with VirtualBox 6.1.6. They both boot in BIOS mode, but seemingly whatever I try, GRUB seems to load the kernel and initrd and then I just get a black screen and nothing happens.

If it’s any help, my system uses an AMD Ryzen 3600 processor, and the VM is allocated 2 GB of RAM.

Any ideas?

Yeah, I forgot about the host. I’m running Mint 19.3.

The rest of my settings are the same as yours, and I even upped the RAM to 4 GB in case 2 GB isn’t enough for some reason.

Perhaps this only happens on AMD CPUs?

I’ll have a quick go on Windows 10 to see if that works.

Even better. If your host is GNU/Linux already, why don’t you use virt-manager to power and manage your VM? (sudo apt-get install virt-manager).

Maybe - can’t tell, never had one of those.

It worked on Windows 10, so I just deleted and re-created my VM configuration, and now it works. No idea what was wrong, but maybe just because I’ve upgraded through a lot of VirtualBox versions over the years with this configuration.

Regardless, not a problem in Fedora :slight_smile: Thanks for the help!


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.