Unable to find graphics card when using Vulkan


I’m trying to play games using Steam’s Proton software, but I’m having issues with getting Vulkan to work.

In my troubleshooting, I’ve tried installing vkmark and vulkan-tools, but neither of these tools is working. First, the output of vulkaninfo:

ERROR: [Loader Message] Code 0 : /usr/lib/libvulkan_radeon.so: wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : /usr/lib/libvulkan_intel.so: wrong ELF class: ELFCLASS32
vulkaninfo/vulkaninfo.h:477: failed with ERROR_INITIALIZATION_FAILED

And vkmark:

Error: vk::Instance::enumeratePhysicalDevices: ErrorInitializationFailed

The Proton log has similar messages:

warn:  D3D11CoreCreateDevice: Adapter is not a DXVK adapter
9251.346:00b8:00bc:trace:loaddll:load_native_dll Loaded L"C:\\windows\\system32\\dxvk_config.dll" at 0x69240000: native
info:  Game: Sniper3Launcher.exe
info:  DXVK: v1.7-8-g51531e4a7
info:  Built-in extension providers:
info:    Win32 WSI
info:    OpenVR
9251.357:00b8:00bc:trace:loaddll:load_native_dll Loaded L"C:\\windows\\system32\\openvr_api_dxvk.dll" at 0x10000000: native
warn:  OpenVR: Failed to initialize OpenVR
info:  Enabled instance extensions:
info:    VK_KHR_get_surface_capabilities2
info:    VK_KHR_surface
info:    VK_KHR_win32_surface
9251.403:00b8:00bc:err:vulkan:wine_vk_instance_load_physical_devices Failed to enumerate physical devices, res=-3
9251.403:00b8:00bc:err:vulkan:wine_vkCreateInstance Failed to load physical devices, res=-3
9251.406:00b8:00bc:trace:seh:MSVCRT_raise (22)
Unable to read VR Path Registry from C:\users\steamuser\Local Settings\Application Data\openvr\openvrpaths.vrpath
terminate called after throwing an instance of 'dxvk::DxvkError'

I’m using an AMD Radeon R9 280X graphics card. It’s a little on the older side, but my understanding is that Vulkan is something the driver has to support rather than the card itself. Is this correct, or is there an issue with the age of the GPU?


I’ve upgraded to Fedora 32 since my last post and I’m still getting this issue.

I finally fixed this problem by following this guide.

I tried summarizing the steps here but I really can’t be more succinct than the steps in the linked article. Here’s an archive link in case the page is taken down or something else breaks the first link: http://archive.is/EGDIp

For me, I needed to use the AMDGPU driver instead of radeon. I added radeon.si_support=0 amdgpu.si_support=1 to the end of GRUB_CMDLINE_LINUX in /etc/default/grub and regenerated the GRUB config file, then rebooted. Now I get good output from vulkaninfo and games run at least as well as they used to in Windows (in my opinion they run better). Hopefully this is helpful to someone else in the future.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.