Unable to enable/connect to WIFI on newly installed Fedora kinoite 38

Hi Team,

I have recently installed Fedora Kinoite 38 version on my HP laptop, I have choosen manual partition erased the windows OS completely and installed Fedora 38. After that I am unable to connect/enable wifi.

Output of inxi -Fzxxx

$ inxi -Fzxxx
  Kernel: 6.2.9-300.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.39-9.fc38 clocksource: tsc Desktop: KDE Plasma v: 5.27.4 tk: Qt
    v: 5.15.8 wm: kwin_wayland vt: 2 dm: SDDM Distro: Fedora release 38
    (Thirty Eight)
  Type: Laptop System: Hewlett-Packard product: HP Pavilion g6 Notebook PC
    v: 0792100000205610000610100 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 183E v: 56.32 serial: <superuser required>
    UEFI-[Legacy]: Insyde v: F.25 date: 05/29/2013
  ID-1: BAT0 charge: 26.3 Wh (78.5%) condition: 33.5/33.5 Wh (100.0%)
    volts: 12.4 min: 10.8 model: Hewlett-Packard Primary type: Li-ion
    serial: N/A status: charging
  Info: dual core model: Intel Core i5-3210M bits: 64 type: MT MCP
    smt: enabled arch: Ivy Bridge rev: 9 cache: L1: 128 KiB L2: 512 KiB
    L3: 3 MiB
  Speed (MHz): avg: 2145 high: 3093 min/max: 1200/3100 cores: 1: 3087
    2: 3093 3: 1200 4: 1200 bogomips: 19953
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-7 ports: active: LVDS-1
    empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0166
    class-ID: 0300
  Device-2: AMD Thames [Radeon HD 7500M/7600M Series]
    vendor: Hewlett-Packard driver: radeon v: kernel arch: TeraScale-2 pcie:
    speed: 2.5 GT/s lanes: 8 bus-ID: 01:00.0 chip-ID: 1002:6840 class-ID: 0300
    temp: 51.0 C
  Device-3: Cheng Uei Precision Industry (Foxlink) HP Webcam-50
    driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 4-1.5:4
    chip-ID: 05c8:0222 class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: kwin_wayland driver: N/A display-ID: 0
  Monitor-1: LVDS-1 res: 1366x768 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel crocus drv: amd r600 platforms: device: 0
    drv: r600 device: 1 drv: crocus device: 2 drv: swrast gbm: drv: r600
    surfaceless: drv: crocus wayland: drv: crocus x11: drv: crocus
  API: OpenGL v: 4.2 vendor: intel mesa v: 23.0.1 glx-v: 1.4 es-v: 3.0
    direct-render: yes renderer: Mesa Intel HD Graphics 4000 (IVB GT2)
    device-ID: 8086:0166 display-ID: :0.0
  API: Vulkan v: 1.3.239 layers: 1 surfaces: xcb,xlib,wayland device: 0
    type: integrated-gpu driver: mesa intel device-ID: 8086:0166 device: 1
    type: cpu driver: mesa llvmpipe device-ID: 10005:0000
  Device-1: Intel 7 Series/C216 Family High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1e20 class-ID: 0403
  API: ALSA v: k6.2.9-300.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.67 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    vendor: Dell driver: ath9k v: kernel pcie: speed: 2.5 GT/s lanes: 1
    bus-ID: 07:00.0 chip-ID: 168c:0036 class-ID: 0280
  IF: wlp7s0 state: down mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 08:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 465.76 GiB used: 4.51 GiB (1.0%)
  ID-1: /dev/sda vendor: Seagate model: ST500LM030-2E717D size: 465.76 GiB
    speed: 3.0 Gb/s tech: HDD rpm: 5400 serial: <filter> fw-rev: SDM1
    scheme: MBR
  ID-1: /boot size: 973.4 MiB used: 100.9 MiB (10.4%) fs: ext4 dev: /dev/sda1
  ID-2: /var size: 171.79 GiB used: 4.41 GiB (2.6%) fs: btrfs dev: /dev/sda2
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 80.0 C mobo: N/A gpu: radeon temp: 51.0 C
  Fan Speeds (rpm): N/A
  Processes: 240 Uptime: 8m wakeups: 1 Memory: total: 12 GiB
  available: 11.57 GiB used: 3.67 GiB (31.7%) Init: systemd v: 253
  target: graphical (5) default: graphical Compilers: N/A Packages: pm: rpm
  pkgs: N/A note: see --rpm Shell: Bash v: 5.2.15 running-in: konsole
  inxi: 3.3.30

Output from rfkill

[garuda@fedora garuda]$ rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes

output from lspci

[garuda@fedora garuda]$ lspci -vvk -s 07:00.0
07:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
        Subsystem: Dell Device 020c
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at c3500000 (64-bit, non-prefetchable) [size=512K]
        Expansion ROM at c3580000 [disabled] [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: ath9k
        Kernel modules: ath9k

output from lsmod

[garuda@fedora garuda]$ lsmod |grep ath9k
ath9k                 188416  0
ath9k_common           28672  1 ath9k
ath9k_hw              565248  2 ath9k_common,ath9k
mac80211             1486848  1 ath9k
ath                    40960  3 ath9k_common,ath9k,ath9k_hw
cfg80211             1269760  4 ath9k_common,ath9k,ath,mac80211
rfkill                 40960  6 hp_wmi,ath9k,cfg80211

Output from nmcli

[garuda@fedora garuda]$ nmcli d
DEVICE  TYPE      STATE                   CONNECTION 
eno1    ethernet  connected               eno1       
lo      loopback  connected (externally)  lo         
wlp7s0  wifi      unavailable             --         

Output from Ifconfig up

[garuda@fedora garuda]$ sudo ifconfig wlp7s0 up
SIOCSIFFLAGS: Operation not possible due to RF-kill

I have tried all this, but I am unable to connect to wifi. Your feedback and help would be very helpful for me.

This shows that the wifi is hard blocked and cannot be configured.

Does your laptop have a switch to enable/disable the wifi?
If so you might change it to enabled then try configuring it again.

It may be a setting in bios or it may be a physical switch or it may be a key combination on the keyboard.

1 Like

Yes Jeff, I have a switch on the F12 Key. However if I press the key it is not turning on. But what happens is that if I goto sleep menu on the application launcher the laptop is going to sleep mode. Then when I press the checkbox infront of wifi icon on the bottom right, then it is working and it is letting me to connect to WiFi. Again when I switch off or restart the maching, I am unable to connect to Wifi.
Do you know what could be the problem behind this and how to check why after going to sleep mode the wifi and bluetooth is working?

It would seem that icon checkbox is performing the same as the F12 key is supposed to.

Note that the F12 key is probably intended to perform that function within windows and is likely not mapped the same when in Linux.

Have you checked within bios to see if there is a setting there that would permanently enable wifi? That would be the next thing I would check.

You also could look within the settings and see if there is another key mapping that might enable wifi as well – it appears the F12 function does not.

HP notebook using a Dell device! Is the wifi hardware original or a replacement? This might affect how the rfkill switch works.

I tried to go into to BIOS for the setting, but unfortunately there is no setting to enable the wifi or F12 key in BIOS.
is there anyway to find out what happens, like what process are getting restarted for the WIFI when I enter and leave the sleep mode?
Could it be a fault with the inbuild wifi chip in the laptop?

Even when I saw the output I was wondering why it is displaying like Dell Device 020c, when my wifi hardware is realtek.

Chips have a 4-part ID: “vendor:ID:subvendor:subID”. The subvendor is is often the system maker. Big vendors like HP and Dell have their own special sauce for power management and may use vendor/model-specific ways (BIOS, function key, or dedicated switch) wifi is disabled. The big vendors buy enough chips that they can order customized versions. With chip shortages in recent years, it is possible that HP used chips originally designed for Dell, or that somewhere in the history of your machine the original wifi was replaced. It would be interesting to see what other HP systems of similar vintage use for wifi. You can do that with the Linux Hardware Database.