Unable to customize pipewire daemon to include RAOP Discover on boot

I’ve been trying to configure pipewire to load the context.module libpipewire-module-raop-discover loaded on login. However, when attempting to implement the steps detailed on https://docs.pipewire.org/ results in no sound outputs.

Current system:
Fedora Linux 40 (Workstation Edition) - System is defined as PT-PT
Intel_R_ Client Systems NUC8i7BEH
System Memory 16,0 GiB
Processor Intel® Core™ i7-8559U × 8
Graphics Intel® Iris® Plus Graphics 655 (CFL GT3)
GNOME 46
Window management Wayland
Kernel Version Linux 6.8.9-300.fc40.x86_64

Steps taken

  1. Copied the contents of /usr/share/pipewire to ~/.config/pipewire

    reboot revealed that sound worked as it did before this change

  2. Created a text file file.confin ~/.config/pipewire/pipewire.conf.d with the contents of the Example configuration available on RAOP Discover documentation.

    reboot left me with no audio outputs (as seen on GNOME Setting App)
    deleted file.conf logged out and logged back in and sound output options were again available

  3. Created a new text file file2.confin ~/.config/pipewire/pipewire.conf.d with the following contents

context.modules = [
{   name = libpipewire-raop-discover
    args = {  }
            }
]

reboot left me with no audio outputs (as seen on GNOME Settings App)
deleted file2.conf logged out and logged back in and sound output options were again available

  1. Tryed troubleshooting procedures (on Terminal)
  • Installed pulseaudio-utils (all sites I read suggested I had to have pactl installed).
  • Ran pactl list modules which listed 21 modules, none of which was libpipewire-module-raop-discover.
  • Ran: pactl load-module module-raop-discover then pactl list modules and the output now presented
Módulo #536870913
	Nome: module-raop-discover
	Argumento: 
	Contador de utilização: n/d
	Propriedades:
		module.author = "Wim Taymans <wim.taymans@gmail.con>"
		module.description = "mDNS/DNS-SD Service Discovery of RAOP devices"
		module.usage = ""
		module.version = "1.0.6"

At this point when I go to Gnome Settings, all my home-network airplay devices are listed and sound output works as expect.

What can I do to have Module RAOP Discover loaded on boot.
What have I done wrong, because as far as I can understand I followed the instruction on https://docs.pipewire.org/ to the letter.

Thank you.