Unable to boot Fedora 39 beta live image from VMware


I cannot boot the Fedora 39 beta live image in the VMWare Workstation 17 Player.
I have already removed the quiet parameter from the boot options.
I get the following error message:

[ 352.297074] systemd[1]: Freezing execution.

The boot image used is:

Before I gave up on VMware Fusion on macOS it was failing to run new Fedora.

Does Fedora 38 work on VMware for you?

If so VMware needs to do something to support newer kernels I suspect.

Fedora37 / 38 work without problems.
Then I have to wait a few days, maybe it works with a newer iso image.

It worked on gnome box i think due to it have newer kernel it does not have support for it.

opened a bugzilla ticket on this topic: 2234653 – unable to boot Fedora 39 beta live image in the VMWare Workstation 17 Player

1 Like

On VMware Fusion, Just tried iso https://download.fedoraproject.org/pub/fedora/linux/releases/test/39_Beta/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-39_Beta-1.1.iso

Did Few more things:

  • Modified CD/DVD controller to SATA instead of IDE from VM settings
  • Powered On to Firmware, Selected the relevant boot option CD-Drive from boot manager
    And all worked fine for me. Probably you can try the same.

by changing the CD/DVD controller in the VM settings
from IDE to SATA, I could also solve the boot problem. thank you.