UEFI dual boot broken since (Fedora and/or Windows) update

Hello all,

I don’t use my secondary system (laptop) that much, so when I do, I always perform a system update. It’s a dual boot system consisting of Fedora 34 and Windows 10 on a SATA SSD (/dev/sda). This week, I performed both Windows- and Fedora updates. The latter contained (among other things) kernel 5.13.4.

The next time I (re)booted the system, GRUB came up as expected; showing the new kernel on top of the list. I chose the Windows bootloader and got an error about unable to find a Windows boot file. I’m sorry; I didn’t write it down to post in this message. Fedora started normally using GRUB.

I then used a Windows installation stick to repair its boot mechanism - and that worked. Too well - since Fedora and GRUB are now no longer starting.

Trying to repair the old, working dual-boot situation, I read about and performed a chroot from a live-system. Even the LUKS part worked as expected. Finally running os-prober in the chroot, I got another error (probably the cause of this problem): cannot find a GRUB file for /dev/sda3 (which is the Windows partition). It then proceeds to add a boot option for entering the UEFI setup.

Having followed the Fedora documentation on the subject, and having failed - How can I re-install GRUB with both Fedora and Windows being available?

Thank you very much,

Not really solved the issue, but saved the day by completely reinstalling Fedora 34.

The installer correctly handled placing of the bootloader and making a true dual-boot system, once again.

Case closed.

Thanks for reading,