Typing emojis with "Ctrl+shift+e" in F35

In F34 I configured my input sources to be able to type emojis using “Ctrl+shift+e”, by adding “Typing Booster” as an input source next to my main input source. This worked nicely and is a super cool feature.

However, the “Ctrl+shift+e” shortcut stopped working after I upgraded to F35. I’ve tried resetting my input sources and configuring them again, but with no luck.

Any idea why?

1 Like

I think this is what you’re seeing:

TLDR: default short cut is now ctrl + period


Indeed, ctrl + period does work (and with a new nicer widget to select the emoji :slight_smile:)!

thank you very much for your swift answer!


To check or change the keyboard shortcuts for the emoji* or unicode code point input methods, launch ibus-setup in a terminal.


* It’s called “Emoji Input” but I find this input method useful for entering characters beyond Emoji — I much prefer it to memorizing unicode code points. Indeed, I deleted the Ctrl+Shift+U keybinding to free it up for applications.

To delete the Ctrl+Shift+U keybinding to free it up for applications,

  1. Launch ibus-setup from a terminal.
  2. Go to the Emoji tab.
  3. Click the ellipsis to the right of Unicode code point.
  4. Click the Delete button.
  5. Add export GTK_IM_MODULE=ibus to your ~/.bash_profile, or set this wherever you prefer to set environment variables.
  6. Log out and back in to let the environment variable take effect.

In my testing, it is no longer necessary to enable more than one IBus engine, such as ibus-typing-booster or ibus-libpinyin, to enable the emoji input method.

1 Like

:flying_disc: ctrl-. follow by space bar brings menu for emojis

1 Like

I often bypass the menu if I know precisely which character I want. For example, to enter Em Dash (U+2014), I type the following:

  1. Ctrl + PERIOD to activate the pre-edit buffer for emoji
  2. em dash (Note: to enter a space it is necessary to press Shift + SPACE)
  3. SPACE
  4. ENTER