Turning up refresh rate causes monitor to have no signal

Hey, I recently installed Fedora 35, and when I try to turn up refresh rate above 120hz on my main monitor, it goes to no signal. 120hz and below all work fine. On my second monitor I’m able to pick all hz settings available without issue (155hz and below). If there’s any other information required to help solve my problem, please ask. Thank you all in advance for the help! :slight_smile:

It sounds like that monitor is being sent a signal it can’t handle. Are you sure it supports the specific input your are sending it?

Yep, my monitor supports 165hz, but anything above 120hz sends no signal. For additional context, the monitor I can’t go above 120hz on is a 2721DGF monitor from Dell

You are right that dell says it can support 165 hz (on the DP only). It cannot go above 144 hz on HDMI.

This from Dell @

Native Resolution
2560 x 1440 at 144 Hz (Native with HDMI)
2560 x 1440 at 165 Hz (Native with DP)

Do note that I am using a DP cable, not an HDMI.

Hi, what graphic card you’re currently using? If you’re using nvidia, which driver you’re currently using, nouveau or nvidia? And the last, what session you’re currently at, wayland or xorg?

I’m using a 2080 Super for my GPU, nvidia driver version 495.44, and I appear to be using x11

Update: Even though when I tried to use X Server last night, it still didn’t let me use anything above 120hz, even though I didn’t restart my pc overnight, NVIDIA X Server now seems to be able to set my monitor to 165hz and everything below just fine (Just tried it, the display manager in settings now seems to be able to set it to 165hz just fine…). Very sorry that I don’t really know what solved this in case anyone else has this issue.

1 Like

Hi, would you like to post the content of /etc/X11/xorg.conf? I just migrating my other old laptop that have Nvidia gpu to Fedora and found in xorg.conf there are configuration like this:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"

If your xorg.conf have number values at range exactly same with what your current monitor refresh rate, maybe it will help to give a clue if some one come here and facing the same problem.