Turn on and off menu_auto_hide

I need to boot into kernel 6.3 because 6.4 is causing high GPU utilization during gaming sessions.

I’ve used the command below to unhide the grub menu and it works
sudo grub2-editenv - unset menu_auto_hide

In the future I’d to set it back to hide the menu however, this command throws an error invalid parameter menu_auto_hide. What is the command to set it back to default?

sudo grub2-editenv - set menu_auto_hide

Not sure what’s wrong in 6.4 but games now push my 7900 XTX to 100% utilization and low fps when it didn’t perform like that previously. This is preventing me from playing Battlebit :smiley:

We need much more info to assist in determining why the high CPU usage.
Please post the output of inxi -Fzxx

As far as hiding the grub menu the command would be
sudo grub2-editenv - set menu_auto_hide=1
Your command did not set the actual value.

Thanks for the reply Jeff, to be clear it’s GPU utilization not CPU. Here’s the results
Kernel 6.3.12 works as expected.

  Kernel: 6.4.6-200.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.39-9.fc38 Desktop: GNOME v: 44.3 tk: GTK v: 3.24.38 wm: gnome-shell
    dm: GDM Distro: Fedora release 38 (Thirty Eight)
  Type: Desktop System: Gigabyte product: X570 AORUS MASTER v: -CF
    serial: <superuser required>
  Mobo: Gigabyte model: X570 AORUS MASTER serial: <superuser required>
    UEFI: American Megatrends LLC. v: F37c date: 03/23/2023
  Info: 8-core model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3+
    rev: 0 cache: L1: 512 KiB L2: 4 MiB L3: 32 MiB
  Speed (MHz): avg: 930 high: 3598 min/max: 550/5085 cores: 1: 550 2: 550
    3: 550 4: 550 5: 550 6: 3598 7: 550 8: 550 9: 550 10: 550 11: 3597 12: 550
    13: 550 14: 550 15: 550 16: 550 bogomips: 121604
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX] vendor: Tul / PowerColor
    driver: amdgpu v: kernel arch: RDNA-3 pcie: speed: 16 GT/s lanes: 16 ports:
    active: DP-3 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0d:00.0 chip-ID: 1002:744c
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: gnome-shell driver: gpu: amdgpu display-ID: 0
  Monitor-1: DP-3 model: LG (GoldStar) ULTRAGEAR+ res: 3840x2160 dpi: 163
    diag: 690mm (27.2")
  API: OpenGL v: 4.6 Mesa 23.1.4 renderer: AMD Radeon Graphics (gfx1100
    LLVM 16.0.6 DRM 3.52 6.4.6-200.fc38.x86_64) direct-render: Yes
  Device-1: Creative Labs CA0132 Sound Core3D [Sound Blaster Recon3D /
    Z-Series BlasterX AE-5 Plus] driver: snd_hda_intel v: kernel pcie:
    speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 1102:0012
  Device-2: AMD driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s
    lanes: 16 bus-ID: 0d:00.1 chip-ID: 1002:ab30
  API: ALSA v: k6.4.6-200.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.75 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: speed: 5 GT/s
    lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2723
  IF: wlp5s0 state: down mac: <filter>
  Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb
    v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 06:00.0
    chip-ID: 8086:1539
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-3: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
    pcie: speed: 5 GT/s lanes: 1 port: d000 bus-ID: 07:00.0 chip-ID: 10ec:8125
  IF: enp7s0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 3-5:2 chip-ID: 8087:0029
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 931.51 GiB used: 444.83 GiB (47.8%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDBA3V0010BNC-WRSN
    size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 46.9 C
  ID-1: / size: 929.93 GiB used: 444.49 GiB (47.8%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 333.4 MiB (34.2%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 929.93 GiB used: 444.49 GiB (47.8%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 42.9 C mobo: 39.0 C gpu: amdgpu temp: 49.0 C
    mem: 58.0 C
  Fan Speeds (RPM): fan-1: 0 fan-2: 0 fan-3: 0 gpu: amdgpu fan: 0
  Power: 12v: N/A 5v: N/A 3.3v: 3.36 vbat: 3.21
  Processes: 510 Uptime: 2m Memory: available: 31.25 GiB
  used: 3.13 GiB (10.0%) Init: systemd v: 253 target: graphical (5)
  default: graphical Compilers: gcc: 13.1.1 Packages: pm: rpm pkgs: N/A
  note: see --rpm pm: flatpak pkgs: 43 Shell: Bash v: 5.2.15
  running-in: flatpak-session inxi: 3.3.27

Have you tried to log in using Xorg instead of wayland to see if you have the same issue.

Just tried with X.org and it does perform better. I don’t want to give the Wayland haters any more ammo :laughing:

1 Like

One would note that playing games almost always has high gpu utilization since they seem to be very graphics intensive. I believe this is the main reason graphics cards are continuously being improved and made more powerful. Hardware acceleration on the GPU is also very GPU intensive.

How active the GPU is seems based upon what the user is running. In fact I run boinc with tasks that use the GPU exclusively and it remains at nearly 100% a large portion of the time. As long as GPU temps are stable and not extremely high I would not worry about that.

Mine shows this

$ nvidia-smi
Sun Jul 30 18:39:32 2023       
| NVIDIA-SMI 535.86.05              Driver Version: 535.86.05    CUDA Version: 12.2     |
| GPU  Name                 Persistence-M | Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |         Memory-Usage | GPU-Util  Compute M. |
|                                         |                      |               MIG M. |
|   0  NVIDIA GeForce RTX 3050        Off | 00000000:06:00.0  On |                  N/A |
| 30%   60C    P2             104W / 130W |   1046MiB /  8192MiB |     98%      Default |
|                                         |                      |                  N/A |

98% load and only 60C and about 3/4 of full power load.