Troubleshooting GNOME Interface Unresponsiveness after Deleting DNF Cache on Fedora 39

I encountered a problem with my Linux system running Fedora 39 after executing the following command:

sudo rm -rfv /var/cache/dnf/*

I know now that I should have used it

dnf clean all

Initially, I believed these were just temporary files. However, after this action, the GNOME interface ceased to function entirely, and the following image appeared:

enter image description here

Furthermore, the logs generated by the command:

journalctl -xe

are provided here:

enter image description here

I attempted the following solutions without success:

1- Update DNF packages:

sudo dnf update
sudo dnf upgrade
sudo dnf reinstall "*"

2- Create a new user to test for potential GNOME configuration issues, but this did not resolve the problem.

I am seeking guidance on how to address and resolve this issue. Any assistance or suggestions would be greatly appreciated.

I have often cleaned the /var/cache/dnf directory this way, and when you run dnf check-upgrade the files and directories will be recreated as needed.

It is highly unlikely that this could have been the cause of Gnome not starting.

1 Like

Can you help me with a way to know what the reason is and treat it, because I did not understand the reason, and the last thing I did was this, so I linked the events together.

Hello @wissamalkahwaji ,
It could be related to Gnome software having to rebuild the cache info after you deleted the contents. This would only apply initially upon the next Gnome Software refreshing data (checking for updates). Can you get to a terminal at the time it happens? ie <ctrl><alt><f2> ?

Yes, I only use Terminal, but I cannot use gnome
I ran this command and no fix occurred

sudo dnf reinstall "*"

What was the response to that command?
[Edit]: I’m just not positive the wildcard is the best solution with reinstall.

Unless you mistyped a space between /var/dnf/cache/ and *, the command is no problem, I think it is more or less equivalent to “dnf clean cache”.
That leads to the question: what did you before? Big update?
Have you already tried to boot a previous kenel for the case the latest kernel and your graphic card do not like each other?
For the rest, if the rpm database is intact, all files should be OK thanks dnf reinstall, and you excluded user config problems by creating another user. The gnome error and the “libxcb” in the crash traceback point into the graphics subsystem.

I think “dnf reinstall” has given you a new copy of the cache so this could not lead to a chain of problems within gnome.

I also don’t think it is dnf related, but likely configuration issue. Probably graphics related, but could be extension related. I would delete my extensions then try again.

According to the log, your running gnome on X11. As workaround, have you already tried gnome/wayland? If you’re running gdm as display manager, there should be a gear where you can switch between gnome/“gnome classic” in Wayland or X11 version.

I recently discovered that you can run “gnome-shell --wayland” in a console. (kill with “killall gnome-shell” from another console).
May be this gives some other info about the problem in the console.

I will try this when I get home, I hope it works

You can create a cache to with dnf :

dnf --help |grep cache
clean                     remove cached data
makecache                 generate the metadata cache
  -C, --cacheonly       run entirely from system cache, don't update cache

Is not that what you looked for?

Oh no! message topics:

I switched to the KDE framework and the problem was from gnome with an unknown job. I tried many settings and reinstalled them. The problem was the same, so I used KDE and the problem was solved like this.