Troubles with RPMfusion nvidia drivers + SecureBoot setup |

Probably, and more so for most of the systems. But there are some documented posts in other forums/distros that this had (rarely) happened, and that the GDM delay did solve the issue. I won’t post links, they would be counterproductive for this already long thread.

However, it would be a really good explanation why at boot time Wayland is not available, but after a login-logout loop it appears in the GDM sessions cogwheel menu.

Unfortunately I don’t have the issue with Wayland not being available at login, as I would have otherwise confirmed the workaround, having tested it already.

if you tell me what to do i can try the work around , no pb

Please see the steps described in my post above.

Just make sure you add those 2 lines at the right place, as indicated by the comments in the opened config file.

before doing anything stupid this ist what i get with the 1st CLI ( sudo systemctl edit gdm)
Let me know where to put [service] ExecStartPre=/usr/bin/sleep 3

      /etc/systemd/system/gdm.service.d/.#override.conf13c9c8fd1a420e65                
### Editing /etc/systemd/system/gdm.service.d/override.conf
### Anything between here and the comment below will become the contents of the drop-in>



### Edits below this comment will be discarded


### /usr/lib/systemd/system/gdm.service
# [Unit]
# Description=GNOME Display Manager
# 
# # replaces the getty
# Conflicts=getty@tty1.service
# After=getty@tty1.service
# 
# # replaces plymouth-quit since it quits plymouth on its own
# Conflicts=plymouth-quit.service
# After=plymouth-quit.service
# 
# # Needs all the dependencies of the services it's replacing
# # pulled from getty@.service and plymouth-quit.service
# # (except for plymouth-quit-wait.service since it waits until
# # plymouth is quit, which we do)
# After=rc-local.service plymouth-start.service systemd-user-sessions.service
# 
# # GDM takes responsibility for stopping plymouth, so if it fails
# # for any reason, make sure plymouth still stops
# OnFailure=plymouth-quit.service
# 
# [Service]
# ExecStart=/usr/sbin/gdm
# KillMode=mixed
# Restart=always
# IgnoreSIGPIPE=no
# BusName=org.gnome.DisplayManager
# EnvironmentFile=-/etc/locale.conf
# ExecReload=/bin/kill -SIGHUP $MAINPID
# KeyringMode=shared
# 
# [Install]
# Alias=display-manager.service

### /usr/lib/systemd/system/service.d/10-timeout-abort.conf
# # This file is part of the systemd package.
# # See https://fedoraproject.org/wiki/Changes/Shorter_Shutdown_Timer.
# #
# # To facilitate debugging when a service fails to stop cleanly,
# # TimeoutStopFailureMode=abort is set to "crash" services that fail to stop in
# # the time allotted. This will cause the service to be terminated with SIGABRT
# # and a coredump to be generated.
# #
# # To undo this configuration change, create a mask file:
# #   sudo mkdir -p /etc/systemd/system/service.d
# #   sudo ln -sv /dev/null /etc/systemd/system/service.d/10-timeout-abort.conf
# 
# [Service]
# TimeoutStopFailureMode=abort

Right below the line:

### Anything between here and the comment below will become the contents of the drop-in>

Remember to keep the correct syntax.

Copy/ paste is fine , right ?

Yes, it is.

1 Like

Did a reboot still have only 2 choices at logging and 4 choices after log out/ log in

It might have been a red herring then.

i supposed i can erased those lines that i just put in ?

Just deleting the lines wouldn’t work, given that you don’t have an actual file on the terminal screen output.

With the inserted 2 rows, a new config file has been created. That one has to be deleted.

  • First make sure you’re looking at the correct file:
sudo cat /etc/systemd/system/gdm.service.d/override.conf

The two lines added previously should be on the output.

  • Then delete the file:
sudo rm /etc/systemd/system/gdm.service.d/override.conf
  • Make sure the default setup has been restored:
sudo systemctl edit gdm

The output should be as before the changes.

1 Like

I concur with @theduc
Adding the sleep for gdm did not change the login and the system will still only boot with the 2 choices for selecting a DE for login.

I think this may be a show stopper for F41 which will no longer contain X11 by default and may easily break fedora totally (make cold boot and login difficult) for those systems where this is a symptom of some some deeper and unidentified problem.

Could it be ‘mutter’ or plymouth ?

$ fastfetch
             .',;::::;,'.                    ME@eagle
         .';:cccccccccccc:;,.             -----------
      .;cccccccccccccccccccccc;.          OS: Fedora Linux 40 (Workstation Edition) x86_64
    .:cccccccccccccccccccccccccc:.        Host: B550M Pro4
  .;ccccccccccccc;.:dddl:.;ccccccc;.      Kernel: Linux 6.9.7-200.fc40.x86_64
 .:ccccccccccccc;OWMKOOXMWd;ccccccc:.     Uptime: 8 mins
.:ccccccccccccc;KMMc;cc;xMMc;ccccccc:.    Packages: 4155 (rpm), 18 (flatpak-system), 3 (flatpak-user)
,cccccccccccccc;MMM.;cc;;WW:;cccccccc,    Shell: bash 5.2.26
:cccccccccccccc;MMM.;cccccccccccccccc:    Display (LG TV SSCR2): 3840x2160 @ 30Hz *
:ccccccc;oxOOOo;MMM000k.;cccccccccccc:    Display (MP59HT): 1920x1080 @ 75Hz
cccccc;0MMKxdd:;MMMkddc.;cccccccccccc;    DE: GNOME 46.2
ccccc;XMO';cccc;MMM.;cccccccccccccccc'    WM: Mutter (X11)
ccccc;MMo;ccccc;MMW.;ccccccccccccccc;     WM Theme: Adwaita
ccccc;0MNc.ccc.xMMd;ccccccccccccccc;      Theme: Adwaita [GTK2/3/4]
cccccc;dNMWXXXWM0:;cccccccccccccc:,       Icons: Adwaita [GTK2/3/4]
cccccccc;.:odl:.;cccccccccccccc:,.        Font: Cantarell (11pt) [GTK2/3/4]
ccccccccccccccccccccccccccccc:'.          Cursor: Adwaita (24px)
:ccccccccccccccccccccccc:;,..             Terminal: GNOME Terminal 3.50.1
 ':cccccccccccccccc::;,.                  Terminal Font: Source Code Pro (10pt)
                                          CPU: AMD Ryzen 7 5700X (16) @ 3.40 GHz
                                          GPU: NVIDIA Geforce RTX 3050 [Discrete]
                                          Memory: 4.35 GiB / 31.26 GiB (14%)
                                          Swap: 0 B / 8.00 GiB (0%)
                                          Disk (/): 135.98 GiB / 392.65 GiB (35%) - ext4
                                          Disk (/home): 5.83 TiB / 7.22 TiB (81%) - ext4
                                          Local IP (wlp5s0): 192.168.X.XXX/22 *
                                          Locale: en_US.UTF-8

Additional notes that may be a clue:

My primary display is the LG TV shown above.
It does not activate until the last few seconds of the boot (I have removed ‘quiet rhgb’ from the command line options and have the grub menu always displayed) and then displays in the normal 4k resolution while showing the text of booting. When plymouth displays the login screen it is only at HD resolution (1920x1080). After I login the DE display returns to the 4k resolution.

If I do the logout/login loop then the login screen is at the 4k resolution for that login.

Indeed. On the other hand, we don’t know if on the same systems this would be an issue if X11 would be totally missing.

… And it’s one of those issues that can’t be tested on VMs, which would make it much easier to troubleshoot.

How could I test that premise?

I do have an external USB drive that I could install rawhide/f41 onto for testing purposes if the current status of rawhide already excludes x11.

The latest known good release of rawhide for Workstation appears to be Fedora-Rawhide-20240506.n.0 when I look at the nightlies site.

luc@fedora40:~$ fastfetch
             .',;::::;,'.                 luc@fedora40
         .';:cccccccccccc:;,.             ------------
      .;cccccccccccccccccccccc;.          OS: Fedora Linux 40 (Workstation Edit4
    .:cccccccccccccccccccccccccc:.        Kernel: Linux 6.9.7-200.fc40.x86_64
  .;ccccccccccccc;.:dddl:.;ccccccc;.      Uptime: 2 hours, 3 mins
 .:ccccccccccccc;OWMKOOXMWd;ccccccc:.     Packages: 2249 (rpm), 10 (flatpak)
.:ccccccccccccc;KMMc;cc;xMMc;ccccccc:.    Shell: bash 5.2.26
,cccccccccccccc;MMM.;cc;;WW:;cccccccc,    Display (BenQ BL3200): 2560x1440 @ 60*
:cccccccccccccc;MMM.;cccccccccccccccc:    Display (FHD): 1920x1080 @ 60Hz
:ccccccc;oxOOOo;MMM000k.;cccccccccccc:    Display (CG247): 1920x1200 @ 60Hz
cccccc;0MMKxdd:;MMMkddc.;cccccccccccc;    DE: GNOME 46.3.1
ccccc;XMO';cccc;MMM.;cccccccccccccccc'    WM: Mutter (X11)
ccccc;MMo;ccccc;MMW.;ccccccccccccccc;     WM Theme: Graphite-teal-Dark-nord-rims
ccccc;0MNc.ccc.xMMd;ccccccccccccccc;      Theme: Graphite-teal-Dark-nord-rimles]
cccccc;dNMWXXXWM0:;cccccccccccccc:,       Icons: Colloid-pastel [GTK2/3/4]
cccccccc;.:odl:.;cccccccccccccc:,.        Font: Cantarell (11pt) [GTK2/3/4]
ccccccccccccccccccccccccccccc:'.          Cursor: Fuchsia-Amber (24px)
:ccccccccccccccccccccccc:;,..             Terminal: GNOME Terminal 3.50.1
 ':cccccccccccccccc::;,.                  Terminal Font: Source Code Pro (10pt)
                                          CPU: Intel(R) Core(TM) i7-5930K (12) z
                                          GPU: NVIDIA GeForce RTX 3090 [Discret]
                                          Memory: 19.80 GiB / 62.63 GiB (32%)
                                          Swap: 0 B / 8.00 GiB (0%)
                                          Disk (/): 416.62 GiB / 1.82 TiB (22%)s
                                          Disk (/mnt/8bc34d79-424b-47e7-b3b5-b14
                                          Disk (/mnt/fe90c49b-4393-42b9-98f3-b54
                                          Local IP (eno1): 192.168.1.105/24 *
                                          Locale: en_US.UTF-8

                                          ████████████████████████
                                          ████████████████████████
luc@fedora40:~$ 

same behavior with my benq screen 2k which is just active until the last few second of boot which isn't the case for my 2 other screens

In case X11 is still in the default F41/rawhide install, can’t it be removed after installation?

Multiple displays is another thing in common with the OP. I wonder if this is still an issue with only one display connected (maybe the one with smaller resolution).

Appologies if I keep coming up with false leads.

1 Like

Man ,you’re trying to help no need to apologize , at least that’s my way of seeing things…

2 Likes

Hey, I just recently joined the forum so I’m not the most trusted source on this topic but not sure if is a good contribution or not but this guide seems quite organized. It should work with the recent releases as you see in the comment section.

Thanks for the link. This topic is actually much deeper since signing the modules is easy but there are other issues with nvidia and the newer kernels and software.

We are currently discussing why the cold boot or reboot does not allow logging in to wayland but after initial login a logout + login does allow wayland

1 Like